summaryrefslogtreecommitdiffstats
path: root/lurker/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lurker/Makefile.am')
-rw-r--r--lurker/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/lurker/Makefile.am b/lurker/Makefile.am
new file mode 100644
index 0000000..69ea2b9
--- /dev/null
+++ b/lurker/Makefile.am
@@ -0,0 +1,25 @@
+SUBDIRS = mymime libesort common index prune render ui imgs .
+EXTRA_DIST = FAQ
+
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(default_config_dir)
+ @echo
+ @echo "*** PLEASE READ ***"
+ @echo
+ @echo "Lurker config files have not been installed (for your protection)"
+ @echo "If you would like the default config files installed, run:"
+ @echo " make install-config"
+ @echo
+ @echo "*** PLEASE READ ***"
+ @echo
+
+install-config:
+ $(mkinstalldirs) $(DESTDIR)$(localstatedir)/lib/$(PACKAGE)
+ if ! test -f $(DESTDIR)$(localstatedir)/lib/$(PACKAGE)/db; then \
+ echo 1 8192 255 > $(DESTDIR)$(localstatedir)/lib/$(PACKAGE)/db; \
+ fi
+ $(mkinstalldirs) $(DESTDIR)$(default_config_dir)
+ $(INSTALL_DATA) lurker.conf apache.conf $(DESTDIR)$(default_config_dir)
+ @echo
+ @echo "Now put 'include $(default_config_dir)/apache.conf' in your apache config"
+ @echo "And don't forget to setup a cron job as described in the INSTALL file"