aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 31 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index f3de8221..3f9ffb2a 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl
dnl configure.in --- autoconf input file for gawk
dnl
-dnl Copyright (C) 1995-2001 the Free Software Foundation, Inc.
+dnl Copyright (C) 1995-2002 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -25,11 +25,17 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT(awk.h)
AC_PREREQ(2.13)
-AM_INIT_AUTOMAKE(gawk, 3.1.0)
+AM_INIT_AUTOMAKE(gawk, 3.1.1)
AM_CONFIG_HEADER(config.h:configh.in)
dnl Additional argument stuff
AC_ARG_ENABLE(portals, [ --enable-portals Enable /p as path prefix for portals], AC_DEFINE(HAVE_PORTALS))
+AC_ARG_WITH(whiny-user-strftime, [ --with-whiny-user-strftime Force use of included version of strftime for deficient systems],
+ if test "$withval" = yes
+ then
+ AC_DEFINE(USE_INCLUDED_STRFTIME)
+ fi
+)
dnl checks for programs
AC_PROG_YACC
@@ -89,15 +95,17 @@ dnl check for C compiler for automake
AM_PROG_CC_STDC
AM_C_PROTOTYPES
-ALL_LINGUAS="he"
-AM_GNU_GETTEXT
+dnl initialize GNU gettext
+AM_GNU_GETTEXT([no-libtool], [need-ngettext])
dnl checks for header files
AC_HEADER_STDC
AC_HEADER_SYS_WAIT
+AC_HEADER_TIME
AC_CHECK_HEADERS(fcntl.h limits.h locale.h libintl.h mcheck.h \
netdb.h netinet/in.h signum.h stdarg.h string.h \
- sys/param.h sys/socket.h unistd.h)
+ sys/param.h sys/socket.h sys/time.h unistd.h \
+ wchar.h wctype.h)
if test "$ac_cv_header_string_h" = yes
then
@@ -115,6 +123,12 @@ GAWK_AC_TYPE_SSIZE_T
AC_EGREP_HEADER([int.*sprintf], stdio.h,
AC_DEFINE(SPRINTF_RET, int),
AC_DEFINE(SPRINTF_RET, char *))
+dnl see if time_t is defined in <sys/types.h>
+AC_TRY_COMPILE([#include <sys/types.h>],[
+ time_t foo;
+ foo = 0;
+],
+ AC_DEFINE(TIME_T_IN_SYS_TYPES_H))
dnl checks for functions
AC_DEFINE(REGEX_MALLOC)
@@ -128,8 +142,8 @@ yes) AC_DEFINE(HAVE_MKTIME)
esac
AC_CHECK_LIB(m, fmod)
-AC_CHECK_FUNCS(memset memcpy memcmp fmod setlocale strchr strerror \
- strftime strncasecmp strtod system tzset)
+AC_CHECK_FUNCS(getgroups memset memcpy memcmp fmod setlocale strchr strerror \
+ strftime strncasecmp strtod system tzset mbrlen mbrtowc)
dnl check for dynamic linking
dnl This is known to be very primitive
@@ -150,9 +164,9 @@ AC_CHECK_HEADER(dlfcn.h,
dnl check for how to use getpgrp
dnl have to hardwire it for VMS POSIX. Sigh.
-dnl ditto for BeOS.
+dnl ditto for BeOS, OS/2, and MS-DOS.
case `(uname) 2> /dev/null` in
-*VMS*|*BeOS*)
+*VMS*|*BeOS*|*OS/2*|*MS-DOS*)
AC_DEFINE(GETPGRP_VOID)
;;
*) AC_FUNC_GETPGRP
@@ -174,6 +188,14 @@ AC_C_CONST
AC_C_INLINE
AC_C_STRINGIZE
+dnl the following code is for OS/2 only and can be removed if autoconf 2.5x is used
+dnl instead of autoconf 2.13
+PATH_SEPARATOR=':'
+if test `uname` = 'OS/2'; then
+ PATH_SEPARATOR=';'
+fi
+AC_SUBST(PATH_SEPARATOR)
+
AC_OUTPUT(Makefile \
awklib/Makefile \
doc/Makefile \