aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 31 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 27d10b85..7c0cf914 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
dnl
dnl configure.in --- autoconf input file for gawk
dnl
-dnl Copyright (C) 1995-1997 the Free Software Foundation, Inc.
+dnl Copyright (C) 1995-1999 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -30,6 +30,7 @@ dnl This is the configure.in script proper
AC_INIT(awk.h)
AC_PREREQ(2.12)
AC_CONFIG_HEADER(config.h:configh.in)
+AC_CANONICAL_HOST
dnl Additional argument stuff
AC_ARG_ENABLE(bitops, [ --enable-bitops Enable Octal and Hex constants and bit functions], AC_DEFINE(BITOPS))
@@ -61,10 +62,20 @@ dnl go for speed, not debugging. :-)
fi
AC_SUBST(CFLAGS)
+dnl check for Solaris (or other) large file support
+GAWK_AC_SYS_LARGEFILE
+
dnl checks for systems
AC_AIX
AC_ISC_POSIX
AC_MINIX
+GAWK_AC_AIX_TWEAK
+
+if test "$ISC" = 1 # will be set by test for ISC
+then
+dnl need -D_SYSV3 for ISC
+ CFLAGS="$CFLAGS -D_SYSV3"
+fi
dnl checks for header files
AC_HEADER_STDC
@@ -107,7 +118,25 @@ dnl have to hardwire it for VMS POSIX. Sigh.
if (uname) > /dev/null 2>&1
then
case `uname` in
- *VMS*) AC_DEFINE(GETPGRP_VOID) ;;
+ *VMS*|*BeOS*)
+ AC_DEFINE(GETPGRP_VOID)
+ ;;
+ *HP-UX*) # not getpgrp related
+ if test "$GCC" = yes
+ then
+ :
+ else
+ # stupid HP linker leaves the output file
+ # around even when a link fails. This confuses
+ # the alloca tests, so we have to do this
+ # manually. Sucks big time.
+ LIBS="$LIBS -lPW"
+ fi
+
+ # have to do the getpgrp test since won't
+ # fall into the default
+ AC_FUNC_GETPGRP
+ ;;
*) AC_FUNC_GETPGRP
;;
esac