aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index 5e38aac2..9b9db775 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,8 +69,8 @@ endif
SUBDIRS += extras doc awklib po test
# what to make and install
-bin_PROGRAMS = gawk
-bin_SCRIPTS = gawkbug
+bin_PROGRAMS = egawk
+bin_SCRIPTS =
include_HEADERS = gawkapi.h
BUILT_SOURCES = $(srcdir)/pc/Makefile.tst
@@ -150,8 +150,8 @@ RM = rm -f
# Use the transform, in case --program-prefix=XXX
install-exec-hook:
(cd $(DESTDIR)$(bindir); \
- name=`echo gawk | sed '$(transform)'` ; \
- $(LN) $${name}$(EXEEXT) gawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
+ name=`echo egawk | sed '$(transform)'` ; \
+ $(LN) $${name}$(EXEEXT) egawk-$(VERSION)$(EXEEXT) 2>/dev/null ; \
if [ ! -f awk$(EXEEXT) ]; \
then $(LN_S) $${name}$(EXEEXT) awk$(EXEEXT); \
fi; exit 0)
@@ -159,9 +159,9 @@ install-exec-hook:
# Undo the above when uninstalling
uninstall-links:
(cd $(DESTDIR)$(bindir); \
- name=`echo gawk | sed '$(transform)'` ; \
+ name=`echo egawk | sed '$(transform)'` ; \
if [ -f awk$(EXEEXT) ] && cmp awk$(EXEEXT) $${name}$(EXEEXT) > /dev/null; then rm -f awk$(EXEEXT); fi ; \
- rm -f gawk-$(VERSION)$(EXEEXT); exit 0)
+ rm -f egawk-$(VERSION)$(EXEEXT); exit 0)
uninstall-recursive: uninstall-links