aboutsummaryrefslogtreecommitdiffstats
path: root/extension/configure.ac
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2017-12-28 20:15:50 +0200
committerArnold D. Robbins <arnold@skeeve.com>2017-12-28 20:15:50 +0200
commita89622fa57b3cf74e96b9f04c9cae897498155e9 (patch)
treea0da539681ce6fb82db92f799bfa28571ec7fa43 /extension/configure.ac
parent9636262b44d59e5263a60e02f2ca1a22cff566b9 (diff)
downloadegawk-a89622fa57b3cf74e96b9f04c9cae897498155e9.tar.gz
egawk-a89622fa57b3cf74e96b9f04c9cae897498155e9.tar.bz2
egawk-a89622fa57b3cf74e96b9f04c9cae897498155e9.zip
Get rid of GLIBC/compile warnings on Fedora in extension directory.
Diffstat (limited to 'extension/configure.ac')
-rw-r--r--extension/configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/extension/configure.ac b/extension/configure.ac
index e1438259..14259333 100644
--- a/extension/configure.ac
+++ b/extension/configure.ac
@@ -75,9 +75,13 @@ else
AC_MSG_RESULT([no])
fi
-AC_CHECK_HEADERS(fnmatch.h limits.h sys/time.h sys/select.h sys/param.h sys/statvfs.h)
+AC_CHECK_HEADERS(fnmatch.h limits.h sys/mkdev.h sys/param.h sys/select.h \
+ sys/statvfs.h sys/sysmacros.h sys/time.h)
+
AC_HEADER_DIRENT
-AC_HEADER_MAJOR
+dnl 12/2017: AC_HEADER_MAJOR no longer works on recent Fedora / GLIBC.
+dnl Instead we just check for the headers in the call above.
+dnl AC_HEADER_MAJOR
AC_HEADER_TIME
dnl check for mpfr support
@@ -92,8 +96,10 @@ case `uname -m` in
;;
esac
-AC_CHECK_FUNCS(fdopendir fmod fnmatch getdtablesize \
- gettimeofday nanosleep select statvfs GetSystemTimeAsFileTime)
+AC_CHECK_FUNCS(fdopendir fnmatch getdtablesize \
+ gettimeofday nanosleep select statvfs \
+ GetSystemTimeAsFileTime)
+AC_SEARCH_LIBS(fmod, m)
GAWK_FUNC_DIRFD
GAWK_PREREQ_DIRFD