aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2013-03-01 13:44:20 +0200
committerArnold D. Robbins <arnold@skeeve.com>2013-03-01 13:44:20 +0200
commitd8178f354fb1f81c0ed631a25e3ed31dcdadc10e (patch)
tree5d01afdd179a84db9f7c5a83391050c67500cb12 /configure.ac
parentc39c22ef05a188119bbf6da7b80e900ff3fcab31 (diff)
downloadegawk-d8178f354fb1f81c0ed631a25e3ed31dcdadc10e.tar.gz
egawk-d8178f354fb1f81c0ed631a25e3ed31dcdadc10e.tar.bz2
egawk-d8178f354fb1f81c0ed631a25e3ed31dcdadc10e.zip
Make charasbytes test pass on MirBSD.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2f42f4e7..b3087686 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,13 @@ dnl need -D_SYSV3 for ISC
CFLAGS="$CFLAGS -D_SYSV3"
fi
+dnl check for systems where libc is borked for regex handling
+case `uname` in
+MirBSD | MirOS)
+ AC_DEFINE([LIBC_IS_BORKED], 1, [libc is broken for regex handling])
+ ;;
+esac
+
dnl Set the programming language for checks. Fortunately,
dnl this only needs to be set once, since everything is in C.
AC_LANG([C])