aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2017-04-20 06:01:43 +0300
committerArnold D. Robbins <arnold@skeeve.com>2017-04-20 06:01:43 +0300
commit8dcbc1f40d88aa189e7659120ede5436b56a970d (patch)
tree5300da6506ce459975e49290bd67e9afa3262479 /configure.ac
parent7c3d14eb1d103061939fdcad66bf2b27d78bc5b5 (diff)
parent780c96b8a827fd1780e611cd41d59d80033eff46 (diff)
downloadegawk-8dcbc1f40d88aa189e7659120ede5436b56a970d.tar.gz
egawk-8dcbc1f40d88aa189e7659120ede5436b56a970d.tar.bz2
egawk-8dcbc1f40d88aa189e7659120ede5436b56a970d.zip
Merge branch 'master' into feature/api-mpfr
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 17 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index e2226ad9..79a70e3f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,7 +46,7 @@ AC_CONFIG_MACRO_DIR([m4])
dnl Additional argument stuff
AC_ARG_WITH(whiny-user-strftime,
- [AS_HELP_STRING([--with-whiny-user-strftime], [Force use of included version of strftime for deficient systems])],
+ [AS_HELP_STRING([--with-whiny-user-strftime], [force use of included version of strftime for deficient systems])],
if test "$withval" = yes
then
AC_DEFINE(USE_INCLUDED_STRFTIME, 1,
@@ -54,21 +54,21 @@ AC_ARG_WITH(whiny-user-strftime,
fi
)
AC_ARG_ENABLE([lint],
- [AS_HELP_STRING([--disable-lint],[Disable gawk lint checking])],
+ [AS_HELP_STRING([--disable-lint],[do not compile in gawk lint checking])],
if test "$enableval" = no
then
AC_DEFINE(NO_LINT, 1, [disable lint checks])
fi
)
AC_ARG_ENABLE([severe-portability-problems],
- [AS_HELP_STRING([--enable-severe-portability-problems],[Enable really nasty portability problems])],
+ [AS_HELP_STRING([--enable-severe-portability-problems],[allow really nasty portability problems])],
if test "$enableval" = yes
then
AC_DEFINE(I_DONT_KNOW_WHAT_IM_DOING, 1, [enable severe portability problems])
fi
)
AC_ARG_ENABLE([builtin-intdiv0],
- [AS_HELP_STRING([--enable-builtin-intdiv0],[Enable built-in intdiv0 function])],
+ [AS_HELP_STRING([--enable-builtin-intdiv0],[enable built-in intdiv0 function])],
if test "$enableval" = yes
then
AC_DEFINE(SUPPLY_INTDIV, 1, [enable built-in intdiv0 function])
@@ -79,6 +79,15 @@ AC_ARG_ENABLE([builtin-intdiv0],
fi
)
+SKIP_MPFR=no
+AC_ARG_ENABLE([mpfr],
+ [AS_HELP_STRING([--disable-mpfr],[do not check for MPFR])],
+ if test "$enableval" = no
+ then
+ SKIP_MPFR=yes
+ fi
+)
+
AC_CANONICAL_HOST
AC_USE_SYSTEM_EXTENSIONS
@@ -391,7 +400,10 @@ case `uname -m` in
*'Power Macintosh'*)
: ;;
*)
- GNUPG_CHECK_MPFR
+ case $SKIP_MPFR in
+ no) GNUPG_CHECK_MPFR
+ ;;
+ esac
;;
esac