aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrew J. Schorr <aschorr@telemetry-investments.com>2019-08-30 10:42:50 -0400
committerAndrew J. Schorr <aschorr@telemetry-investments.com>2019-08-30 10:42:50 -0400
commit8cc45af919dc56011dbf4c8965b9c1e4784e56d7 (patch)
treee271f42fbc3de7ce1f1e477e700d769bde2fcca4 /configure.ac
parentc15d2db3ce7ea49741d8792190f9212842db86ec (diff)
downloadegawk-8cc45af919dc56011dbf4c8965b9c1e4784e56d7.tar.gz
egawk-8cc45af919dc56011dbf4c8965b9c1e4784e56d7.tar.bz2
egawk-8cc45af919dc56011dbf4c8965b9c1e4784e56d7.zip
In .developing mode, define MEMDEBUG to use malloc/free for block allocation to facilitate finding memory leaks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 436ef4af..7c01f48d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -111,7 +111,7 @@ AC_MSG_CHECKING([for special development options])
if test -f $srcdir/.developing
then
# add other debug flags as appropriate, save GAWKDEBUG for emergencies
- CFLAGS="$CFLAGS -DARRAYDEBUG -DYYDEBUG -DLOCALEDEBUG"
+ CFLAGS="$CFLAGS -DARRAYDEBUG -DYYDEBUG -DLOCALEDEBUG -DMEMDEBUG"
# turn on compiler warnings if we're doing development
# enable debugging using macros also