aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnold D. Robbins <arnold@skeeve.com>2012-06-19 20:57:22 +0300
committerArnold D. Robbins <arnold@skeeve.com>2012-06-19 20:57:22 +0300
commit1ab61e1508bb2c35d536717868d9dbe5ea20fa93 (patch)
treeea4efcbdeff93c87e9213f9b22e55bdaf3d86918 /configure.ac
parentfd3c1195711270a001d860770098b8c0d9118c10 (diff)
downloadegawk-1ab61e1508bb2c35d536717868d9dbe5ea20fa93.tar.gz
egawk-1ab61e1508bb2c35d536717868d9dbe5ea20fa93.tar.bz2
egawk-1ab61e1508bb2c35d536717868d9dbe5ea20fa93.zip
Additional debugging flags at compile time.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 55bf0bab..90ad44b5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -80,7 +80,7 @@ AC_MSG_CHECKING([for special development options])
if test -f $srcdir/.developing
then
# add other debug flags as appropriate, save GAWKDEBUG for emergencies
- CFLAGS="$CFLAGS -DARRAYDEBUG"
+ CFLAGS="$CFLAGS -DARRAYDEBUG -DYYDEBUG"
if grep dbug $srcdir/.developing
then
CFLAGS="$CFLAGS -DDBUG"
@@ -90,7 +90,7 @@ then
# enable debugging using macros also
if test "$GCC" = yes
then
- CFLAGS="$CFLAGS -Wall"
+ CFLAGS="$CFLAGS -Wall -fno-builtin -g3 -gdwarf-2"
fi
AC_MSG_RESULT([yes])
else