aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJuergen Kahrs <Juergen.Kahrs@googlemail.com>2013-05-20 15:58:53 +0200
committerJuergen Kahrs <Juergen.Kahrs@googlemail.com>2013-05-20 15:58:53 +0200
commit1a4fe61b7ad390740a0c70a0175b82301c083704 (patch)
treef12fca4336ddd6792fe6972b5c4c4dfee3ce3bd5 /CMakeLists.txt
parent6013197b678697404fe44e8db58a9d40a2832ce4 (diff)
downloadegawk-1a4fe61b7ad390740a0c70a0175b82301c083704.tar.gz
egawk-1a4fe61b7ad390740a0c70a0175b82301c083704.tar.bz2
egawk-1a4fe61b7ad390740a0c70a0175b82301c083704.zip
CMake and MinGW can build 7 out of 11 extension; 10 out of 18 test SHLIB cases pass.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef31f39a..154d2afb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -53,6 +53,9 @@ if(WIN32 OR "${CMAKE_SYSTEM_NAME}" STREQUAL "Windows")
DefineConfigHValue(HAVE_USLEEP 1)
DefineConfigHValue(STDC_HEADERS 1)
DefineConfigHValue(HAVE_STRINGIZE 1)
+ include_directories(${CMAKE_SOURCE_DIR}/missing_d)
+ DefineConfigHValue(HAVE_MKSTEMP 1)
+ set (EXTRA_LIBS ${EXTRA_LIBS} ws2_32)
# TODO: Eli Zaretskii remined me that the generated
# settings in config.h should be the same as those in
# pc/config.h. With these settings and DYNAMIC=1