summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorcvs2svn <>2004-10-12 23:40:05 +0000
committercvs2svn <>2004-10-12 23:40:05 +0000
commit18b21e9e5c334b56cf52d7c118c1f0a84ea0115c (patch)
treedcd6d3f0ee7dc88c7af6e684fb01451c8bee0e4a /configure.in
parent83ff0aeb3979911d1458c3814eeeceeee4c6d178 (diff)
downloadcygnal-drow_intercu-merge-20040915.tar.gz
cygnal-drow_intercu-merge-20040915.tar.bz2
cygnal-drow_intercu-merge-20040915.zip
This commit was manufactured by cvs2svn to create tag 'drow_intercu-drow_intercu-merge-20040915
merge-20040915'. Sprout from gdb_6_3-branch 2004-10-12 23:40:04 UTC cvs2svn 'This commit was manufactured by cvs2svn to create branch 'gdb_6_3-branch'.' Cherrypick from master 2004-09-14 01:16:22 UTC DJ Delorie <dj@redhat.com> 'merge from gcc': ChangeLog Makefile.in Makefile.tpl config.guess config/ChangeLog config/gettext.m4 configure configure.in include/ChangeLog include/bfdlink.h include/elf/ChangeLog include/elf/arm.h include/elf/common.h include/elf/dwarf2.h include/elf/x86-64.h include/elf/xtensa.h include/opcode/ChangeLog include/opcode/arm.h include/opcode/crx.h include/xtensa-config.h include/xtensa-isa-internal.h include/xtensa-isa.h install-sh ltcf-c.sh ltcf-cxx.sh ltconfig Cherrypick from cygnus 1999-05-03 07:29:06 UTC Richard Henderson <rth@redhat.com> '19990502 sourceware import': ylwrap Delete: config/codeset.m4 config/gcc-lib-path.m4 config/gettext-sister.m4 config/glibc21.m4 config/iconv.m4 config/intdiv0.m4 config/inttypes-pri.m4 config/inttypes.m4 config/inttypes_h.m4 config/lcmessage.m4 config/lib-ld.m4 config/lib-link.m4 config/lib-prefix.m4 config/mh-x86omitfp config/nls.m4 config/po.m4 config/stdint_h.m4 config/uintmax_t.m4 config/ulonglong.m4 config/warnings.m4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 8 insertions, 31 deletions
diff --git a/configure.in b/configure.in
index 0ac43043a..9c32e1209 100644
--- a/configure.in
+++ b/configure.in
@@ -250,8 +250,8 @@ esac
# If both --with-headers and --with-libs are specified, default to
# --without-newlib.
-if test x"${with_headers}" != x && test x"${with_headers}" != xno \
- && test x"${with_libs}" != x && test x"${with_libs}" != xno ; then
+if test x"${with_headers}" != x && test x"${with_headers} != xno \
+ && test x"${with_libs}" != x && test x"${with_libs} != xno ; then
if test x"${with_newlib}" = x ; then
with_newlib=no
fi
@@ -363,10 +363,11 @@ case "${target}" in
;;
powerpc-*-darwin*)
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes gdb gprof"
+ noconfigdirs="$noconfigdirs target-libobjc"
;;
*-*-darwin*)
noconfigdirs="$noconfigdirs bfd binutils ld gas opcodes gdb gprof"
- noconfigdirs="$noconfigdirs ${libgcj}"
+ noconfigdirs="$noconfigdirs target-libobjc ${libgcj}"
;;
*-*-freebsd[[12]] | *-*-freebsd[[12]].* | *-*-freebsd*aout*)
noconfigdirs="$noconfigdirs target-newlib target-libgloss ${libgcj}"
@@ -503,7 +504,7 @@ case "${target}" in
noconfigdirs="$noconfigdirs ${libgcj} target-newlib target-libgloss"
;;
crx-*-*)
- noconfigdirs="$noconfigdirs target-libstdc++-v3 target-mudflap ${libgcj}"
+ noconfigdirs="$noconfigdirs target-libgloss target-libstdc++-v3 target-mudflap ${libgcj}"
;;
d10v-*-*)
noconfigdirs="$noconfigdirs target-libstdc++-v3 target-libgloss ${libgcj}"
@@ -590,9 +591,10 @@ case "${target}" in
target_configdirs="$target_configdirs target-libtermcap target-winsup"
noconfigdirs="$noconfigdirs target-gperf target-libgloss ${libgcj}"
# always build newlib if winsup directory is present.
- if test -d "$srcdir/winsup"; then
+ if test -d "$srcdir/winsup"
+ then
skipdirs=`echo " ${skipdirs} " | sed -e 's/ target-newlib / /'`
- elif test -d "$srcdir/newlib"; then
+ else
echo "Warning: winsup is missing so newlib can't be built."
fi
@@ -936,11 +938,6 @@ case "${host}" in
*-*-sysv4*)
host_makefile_frag="config/mh-sysv4"
;;
- # This is placed last to prevent interfering with the cases above.
- i[[3456789]]86-*-*)
- # Build the stage2 and stage3 compilers with -fomit-frame-pointer.
- host_makefile_frag="config/mh-x86omitfp"
- ;;
esac
fi
@@ -2296,24 +2293,4 @@ case ${enable_werror} in
esac
AC_SUBST(stage2_werror_flag)
-# If gcc is built natively with shared library enabled, set
-# $RPATH_ENVVAR to make sure the newly built gcc shared librares are
-# used.
-SET_GCC_LIB_PATH=
-if test -d ${srcdir}/gcc && test x${is_cross_compiler} = xno; then
- case "${enable_shared}" in
- no | "") ;;
- *)
- eval "d=\$$RPATH_ENVVAR"
- if test x"$d" != x; then
- d="$pwd/gcc:$d"
- else
- d="$pwd/gcc"
- fi
- SET_GCC_LIB_PATH="\$(RPATH_ENVVAR)=$d; export \$(RPATH_ENVVAR);"
- ;;
- esac
-fi
-AC_SUBST(SET_GCC_LIB_PATH)
-
AC_OUTPUT(Makefile)