aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index e154338c..1100cb4c 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -676,6 +676,7 @@ EXTRA_DIST = \
mpfrsqrt.ok \
mpfrstrtonum.awk \
mpfrstrtonum.ok \
+ mpfruplus.ok \
mpgforcenum.awk \
mpgforcenum.ok \
mtchi18n.awk \
@@ -1176,6 +1177,8 @@ EXTRA_DIST = \
uparrfs.awk \
uparrfs.in \
uparrfs.ok \
+ uplus.awk \
+ uplus.ok \
valgrind.awk \
watchpoint1.awk \
watchpoint1.in \
@@ -1251,7 +1254,7 @@ BASIC_TESTS = \
splitdef splitvar splitwht status-close strcat1 strnum1 strnum2 strtod \
subamp subback subi18n subsepnm subslash substr swaplns synerr1 synerr2 \
tradanch tweakfld \
- uninit2 uninit3 uninit4 uninit5 uninitialized unterm uparrfs \
+ uninit2 uninit3 uninit4 uninit5 uninitialized unterm uparrfs uplus \
wideidx wideidx2 widesub widesub2 widesub3 widesub4 wjposer1 \
zero2 zeroe0 zeroflag
@@ -1299,7 +1302,7 @@ MACHINE_TESTS = double1 double2 fmtspcl intformat
MPFR_TESTS = mpfrbigint mpfrexprange mpfrieee mpfrmemok1 mpfrnegzero \
mpfrnr mpfrrem mpfrrnd mpfrrndeval mpfrsort mpfrsqrt \
- mpfrstrtonum mpgforcenum
+ mpfrstrtonum mpgforcenum mpfruplus
LOCALE_CHARSET_TESTS = \
asort asorti backbigs1 backsmalls1 backsmalls2 \
@@ -2123,6 +2126,11 @@ mpfrstrtonum:
@$(AWK) -M -f "$(srcdir)"/$@.awk > _$@ 2>&1
@-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+mpfruplus:
+ @echo $@
+ @$(AWK) -M -f "$(srcdir)"/uplus.awk > _$@ 2>&1
+ @-$(CMP) "$(srcdir)"/$@.ok _$@ && rm -f _$@
+
mpgforcenum:
@echo $@
@$(AWK) -M -f "$(srcdir)"/$@.awk > _$@ 2>&1