aboutsummaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am53
1 files changed, 28 insertions, 25 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index b74056ec..10c5c812 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -133,6 +133,8 @@ EXTRA_DIST = \
assignnumfield.ok \
assignnumfield2.awk \
assignnumfield2.ok \
+ asortbool.awk \
+ asortbool.ok \
awkpath.ok \
back89.awk \
back89.in \
@@ -1436,34 +1438,35 @@ UNIX_TESTS = \
GAWK_EXT_TESTS = \
aadelete1 aadelete2 aarray1 aasort aasorti argtest arraysort \
- arraysort2 arraytype backw badargs beginfile1 beginfile2 binmode1 \
- charasbytes colonwarn clos1way clos1way2 clos1way3 clos1way4 \
- clos1way5 clos1way6 commas crlf dbugeval dbugeval2 dbugeval3 \
- dbugtypedre1 dbugtypedre2 delsub devfd devfd1 devfd2 dfacheck1 \
- dumpvars errno exit fieldwdth forcenum fpat1 fpat2 fpat3 fpat4 \
- fpat5 fpat6 fpat7 fpat8 fpat9 fpatnull fsfwfs funlen functab1 \
- functab2 functab3 functab6 fwtest fwtest2 fwtest3 fwtest4 fwtest5 \
- fwtest6 fwtest7 fwtest8 genpot gensub gensub2 gensub3 getlndir \
- gnuops2 gnuops3 gnureops gsubind icasefs icasers id igncdym igncfs \
- ignrcas2 ignrcas4 ignrcase incdupe incdupe2 incdupe3 incdupe4 \
- incdupe5 incdupe6 incdupe7 include include2 indirectbuiltin \
- indirectcall indirectcall2 inf-nan-torture intarray iolint \
- isarrayunset lint lintexp lintindex lintint lintlength lintplus \
- lintold lintset lintwarn manyfiles match1 match2 match3 mbstr1 \
- mbstr2 mixed1 mktime modifiers muldimposix nastyparm negtime \
- next nondec nondec2 nonfatal1 nonfatal2 nonfatal3 nsawk1a nsawk1b \
- nsawk1c nsawk2a nsawk2b nsbad nsbad_cmd nsforloop nsfuncrecurse \
- nsindirect1 nsindirect2 nsprof1 nsprof2 octdec patsplit posix \
- printfbad1 printfbad2 printfbad3 printfbad4 printhuge procinfs \
- profile0 profile1 profile2 profile3 profile4 profile5 profile6 \
- profile7 profile8 profile9 profile10 profile11 profile12 profile13 \
- profile14 profile15 profile16 pty1 pty2 rebuf regexsub regnul1 regnul2 \
- regx8bit reginttrad reint reint2 rsgetline rsglstdin rsstart1 \
+ arraysort2 arraytype asortbool backw badargs beginfile1 \
+ beginfile2 binmode1 charasbytes clos1way clos1way2 clos1way3 \
+ clos1way4 clos1way5 clos1way6 colonwarn commas crlf dbugeval \
+ dbugeval2 dbugeval3 dbugtypedre1 dbugtypedre2 delsub devfd \
+ devfd1 devfd2 dfacheck1 dumpvars errno exit fieldwdth forcenum \
+ fpat1 fpat2 fpat3 fpat4 fpat5 fpat6 fpat7 fpat8 fpat9 fpatnull \
+ fsfwfs functab1 functab2 functab3 functab6 funlen fwtest fwtest2 \
+ fwtest3 fwtest4 fwtest5 fwtest6 fwtest7 fwtest8 genpot gensub \
+ gensub2 gensub3 getlndir gnuops2 gnuops3 gnureops gsubind \
+ icasefs icasers id igncdym igncfs ignrcas2 ignrcas4 ignrcase \
+ incdupe incdupe2 incdupe3 incdupe4 incdupe5 incdupe6 incdupe7 \
+ include include2 indirectbuiltin indirectcall indirectcall2 \
+ inf-nan-torture intarray iolint isarrayunset lint lintexp \
+ lintindex lintint lintlength lintold lintplus lintset lintwarn \
+ manyfiles match1 match2 match3 mbstr1 mbstr2 mixed1 mktime \
+ modifiers muldimposix nastyparm negtime next nondec nondec2 \
+ nonfatal1 nonfatal2 nonfatal3 nsawk1a nsawk1b nsawk1c nsawk2a \
+ nsawk2b nsbad nsbad_cmd nsforloop nsfuncrecurse nsindirect1 \
+ nsindirect2 nsprof1 nsprof2 octdec patsplit posix printfbad1 \
+ printfbad2 printfbad3 printfbad4 printhuge procinfs profile0 \
+ profile1 profile10 profile11 profile12 profile13 profile14 \
+ profile15 profile16 profile2 profile3 profile4 profile5 profile6 \
+ profile7 profile8 profile9 pty1 pty2 rebuf regexsub reginttrad \
+ regnul1 regnul2 regx8bit reint reint2 rsgetline rsglstdin rsstart1 \
rsstart2 rsstart3 rstest6 sandbox1 shadow shadowbuiltin sortfor \
sortfor2 sortu sourcesplit split_after_fpat splitarg4 strftfld \
strftime strtonum strtonum1 stupid1 stupid2 stupid3 stupid4 stupid5 \
- switch2 symtab1 symtab2 symtab3 symtab4 symtab5 symtab6 symtab7 \
- symtab8 symtab9 symtab10 symtab11 timeout typedregex1 typedregex2 \
+ switch2 symtab1 symtab10 symtab11 symtab2 symtab3 symtab4 symtab5 \
+ symtab6 symtab7 symtab8 symtab9 timeout typedregex1 typedregex2 \
typedregex3 typedregex4 typedregex5 typedregex6 typeof1 typeof2 \
typeof3 typeof4 typeof5 typeof6 watchpoint1