aboutsummaryrefslogtreecommitdiffstats
path: root/support/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'support/Makefile.am')
-rw-r--r--support/Makefile.am61
1 files changed, 61 insertions, 0 deletions
diff --git a/support/Makefile.am b/support/Makefile.am
new file mode 100644
index 00000000..0e198766
--- /dev/null
+++ b/support/Makefile.am
@@ -0,0 +1,61 @@
+#
+# Makefile.am --- automake input file for gawk
+#
+# Copyright (C) 2000-2016 the Free Software Foundation, Inc.
+#
+# This file is part of GAWK, the GNU implementation of the
+# AWK Programming Language.
+#
+# GAWK is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
+#
+# GAWK is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+#
+
+## process this file with automake to produce Makefile.in
+
+# This insures that make flags get passed down to child makes.
+AM_MAKEFLAGS = 'CFLAGS=$(CFLAGS)' 'LDFLAGS=$(LDFLAGS)'
+
+# Stuff to include in the dist that doesn't need it's own
+# Makefile.am files
+EXTRA_DIST = \
+ Makefile.am \
+ Makefile.in \
+ regcomp.c \
+ regex_internal.c \
+ regex_internal.h \
+ regexec.c
+
+# what to make and install
+noinst_LIBRARIES = libsupport.a
+libsupport_a_SOURCES = \
+ dfa.c \
+ dfa.h \
+ getopt.c \
+ getopt.h \
+ getopt_int.h \
+ getopt1.c \
+ intprops.h \
+ localeinfo.c \
+ localeinfo.h \
+ random.c \
+ random.h \
+ regex.c \
+ regex.h \
+ verify.h \
+ xalloc.h
+
+# For some make's, e.g. OpenBSD, that don't define this
+RM = rm -f
+
+DEFS = -DGAWK -DHAVE_CONFIG_H -I"$(srcdir)/.."