aboutsummaryrefslogtreecommitdiffstats
path: root/extension/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'extension/configure.ac')
-rw-r--r--extension/configure.ac22
1 files changed, 6 insertions, 16 deletions
diff --git a/extension/configure.ac b/extension/configure.ac
index 9571f8db..37e306f3 100644
--- a/extension/configure.ac
+++ b/extension/configure.ac
@@ -1,7 +1,7 @@
dnl
dnl configure.ac --- autoconf input file for gawk
dnl
-dnl Copyright (C) 2012, 2013 the Free Software Foundation, Inc.
+dnl Copyright (C) 2012-2014 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -23,7 +23,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNU Awk Bundled Extensions], 4.1.0, bug-gawk@gnu.org, gawk-extensions)
+AC_INIT([GNU Awk Bundled Extensions], 4.1.1, bug-gawk@gnu.org, gawk-extensions)
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
@@ -51,7 +51,7 @@ AC_SUBST([pkgextensiondir], ['${libdir}/gawk'])
if test "$GCC" = yes
then
- CFLAGS="$CFLAGS -Wall -Wextra"
+ CFLAGS="$CFLAGS -Wall" # Don't add -Wextra, hurts older gcc
fi
AC_MSG_CHECKING([for special development options])
@@ -66,9 +66,10 @@ else
AC_MSG_RESULT([no])
fi
+AC_CHECK_HEADERS(fnmatch.h limits.h sys/time.h sys/select.h sys/param.h signal.h)
+AC_HEADER_DIRENT
AC_HEADER_MAJOR
-AC_CHECK_HEADERS(dirent.h fnmatch.h limits.h time.h sys/time.h sys/select.h \
- sys/param.h signal.h)
+AC_HEADER_TIME
AC_CHECK_FUNCS(fcntl fdopendir fnmatch gettimeofday \
getdtablesize kill nanosleep select sigaction sigprocmask \
@@ -83,15 +84,4 @@ AC_C_INLINE
AC_CONFIG_HEADERS([config.h:configh.in])
AC_CONFIG_FILES(Makefile)
-AC_OUTPUT_COMMANDS([
-case `uname` in
-MirBSD | MirOS | "OS/390")
- cat << \EOF > Makefile
-all dist check clean distclean install uninstall distcheck:
- @exit 0
-EOF
- ;;
-*)
-esac
-])dnl
AC_OUTPUT