aboutsummaryrefslogtreecommitdiffstats
path: root/extension/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'extension/configure.ac')
-rw-r--r--extension/configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/extension/configure.ac b/extension/configure.ac
index 2b913364..8d44e2b2 100644
--- a/extension/configure.ac
+++ b/extension/configure.ac
@@ -1,7 +1,7 @@
dnl
dnl configure.ac --- autoconf input file for gawk
dnl
-dnl Copyright (C) 2012-2017 the Free Software Foundation, Inc.
+dnl Copyright (C) 2012-2018 the Free Software Foundation, Inc.
dnl
dnl This file is part of GAWK, the GNU implementation of the
dnl AWK Programming Language.
@@ -25,17 +25,20 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([GNU Awk Bundled Extensions],[4.2.0],[bug-gawk@gnu.org],[gawk-extensions])
+AC_PREREQ([2.69])
+
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([1.15 -Wall -Werror])
+
+
AC_USE_SYSTEM_EXTENSIONS
AC_ZOS_USS
INSTALL="$ac_aux_dir/install-sh -c"
export INSTALL
-AM_INIT_AUTOMAKE([1.15 -Wall -Werror])
-
SKIP_MPFR=no
AC_ARG_ENABLE([mpfr],
[AS_HELP_STRING([--disable-mpfr],[do not check for MPFR])],
@@ -45,6 +48,17 @@ AC_ARG_ENABLE([mpfr],
fi
)
+dnl Set the programming language for checks. Fortunately,
+dnl this only needs to be set once, since everything is in C.
+AC_LANG([C])
+
+dnl initialize GNU gettext
+dnl this seems to help with finding MPFR on some systems, too.
+AM_GNU_GETTEXT([external])
+AM_GNU_GETTEXT_VERSION([0.19.7])
+AM_LANGINFO_CODESET
+gt_LC_MESSAGES
+
dnl checks for structure members
AC_CHECK_MEMBERS([struct stat.st_blksize])