aboutsummaryrefslogtreecommitdiffstats
path: root/extension/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'extension/configure.ac')
-rw-r--r--extension/configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/extension/configure.ac b/extension/configure.ac
index 92ac10d8..b1d00e57 100644
--- a/extension/configure.ac
+++ b/extension/configure.ac
@@ -23,11 +23,13 @@ dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNU Awk Bundled Extensions], 4.0.70, bug-gawk@gnu.org, gawk-extensions)
+AC_INIT([GNU Awk Bundled Extensions], 4.0.73, bug-gawk@gnu.org, gawk-extensions)
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
+AC_USE_SYSTEM_EXTENSIONS
+
INSTALL="$ac_aux_dir/install-sh -c"
export INSTALL
@@ -36,6 +38,7 @@ AM_INIT_AUTOMAKE([-Wall -Werror])
AM_GNU_GETTEXT([external])
AM_GNU_GETTEXT_VERSION([0.18.1])
+
AM_PROG_AR
AC_SYS_LARGEFILE
AC_DISABLE_STATIC
@@ -50,7 +53,7 @@ then
fi
AC_MSG_CHECKING([for special development options])
-if test -f $srcdir/.developing
+if test -f $srcdir/../.developing
then
if test "$GCC" = yes
then
@@ -66,6 +69,9 @@ AC_CHECK_HEADERS(dirent.h fnmatch.h time.h sys/time.h sys/select.h)
AC_CHECK_FUNCS(fdopendir fnmatch gettimeofday \
getdtablesize nanosleep select GetSystemTimeAsFileTime)
+GAWK_FUNC_DIRFD
+GAWK_PREREQ_DIRFD
+
dnl checks for compiler characteristics
AC_C_INLINE