aboutsummaryrefslogtreecommitdiffstats
path: root/extension/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'extension/configure.ac')
-rw-r--r--extension/configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/extension/configure.ac b/extension/configure.ac
index e8b242a0..2b913364 100644
--- a/extension/configure.ac
+++ b/extension/configure.ac
@@ -56,7 +56,9 @@ dnl AC_PROG_INSTALL
dnl use the same definition as the main configure script.
dnl EXTENSIONDIR is exported if it was set there.
-AC_SUBST([pkgextensiondir], ['${pkglibdir}'${EXTENSIONDIR}])
+dnl N.B. We must use ${libdir}/gawk instead of $pkglibdir because $pkglibdir
+dnl is set to ${libdir}/gawk-extensions, which is not what we want.
+AC_SUBST([pkgextensiondir], ['${libdir}/gawk'${EXTENSIONDIR}])
if test "$GCC" = yes
then