aboutsummaryrefslogtreecommitdiffstats
path: root/extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extension/Makefile.am')
-rw-r--r--extension/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/extension/Makefile.am b/extension/Makefile.am
index 185bc795..6ea16f5d 100644
--- a/extension/Makefile.am
+++ b/extension/Makefile.am
@@ -48,6 +48,7 @@ pkgextension_LTLIBRARIES = \
time.la
noinst_LTLIBRARIES = \
+ readdir_test.la \
testext.la
MY_MODULE_FLAGS = -module -avoid-version -no-undefined
@@ -106,6 +107,13 @@ testext_la_SOURCES = testext.c
testext_la_LDFLAGS = $(MY_MODULE_FLAGS) -rpath /foo
testext_la_LIBADD = $(MY_LIBS)
+# N.B. Because we are not installing readdir_test, we must specify -rpath in
+# LDFLAGS to get automake to build a shared library, since it needs
+# an installation path.
+readdir_test_la_SOURCES = readdir_test.c
+readdir_test_la_LDFLAGS = $(MY_MODULE_FLAGS) -rpath /foo
+readdir_test_la_LIBADD = $(MY_LIBS)
+
install-data-hook:
for i in $(pkgextension_LTLIBRARIES) ; do \
$(RM) $(DESTDIR)$(pkgextensiondir)/$$i ; \