aboutsummaryrefslogtreecommitdiffstats
path: root/extension/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'extension/Makefile.am')
-rw-r--r--extension/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/extension/Makefile.am b/extension/Makefile.am
index 54975b8e..1d8e5b03 100644
--- a/extension/Makefile.am
+++ b/extension/Makefile.am
@@ -53,7 +53,7 @@ noinst_LTLIBRARIES = \
testext.la
MY_MODULE_FLAGS = -module -avoid-version -no-undefined
-# on Cygwin, gettext requires that we link with -lintl
+# On Cygwin, gettext requires that we link with -lintl
MY_LIBS = $(LTLIBINTL)
filefuncs_la_SOURCES = filefuncs.c stack.h stack.c gawkfts.h \
@@ -73,9 +73,10 @@ inplace_la_SOURCES = inplace.c
inplace_la_LDFLAGS = $(MY_MODULE_FLAGS)
inplace_la_LIBADD = $(MY_LIBS)
+# On Cygwin, intdiv has to be linked with the MPFR and GMP libraries
intdiv_la_SOURCES = intdiv.c
intdiv_la_LDFLAGS = $(MY_MODULE_FLAGS)
-intdiv_la_LIBADD = $(MY_LIBS)
+intdiv_la_LIBADD = $(MY_LIBS) $(LIBMPFR)
ordchr_la_SOURCES = ordchr.c
ordchr_la_LDFLAGS = $(MY_MODULE_FLAGS)