aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bccd2351..fef29e06 100644
--- a/configure.ac
+++ b/configure.ac
@@ -295,7 +295,9 @@ AC_CHECK_HEADER(dlfcn.h,
if test "$gawk_have_dlopen" = yes
then
AC_DEFINE([DYNAMIC], 1, [dynamic loading is possible])
- if uname | $EGREP -i 'linux|freebsd' > /dev/null
+ # Add -export-dynamic for old extensions. Only works for GCC
+ if test "$GCC" = yes &&
+ uname | $EGREP -i 'linux|freebsd' > /dev/null
then
LDFLAGS="$LDFLAGS -export-dynamic"
fi