aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 3 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 14faf0c8..fd7b73ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,7 +23,7 @@ dnl
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([GNU Awk],[4.2.0f],[bug-gawk@gnu.org],[gawk])
+AC_INIT([GNU Awk],[4.2.60],[bug-gawk@gnu.org],[gawk])
# This is a hack. Different versions of install on different systems
# are just too different. Chuck it and use install-sh.
@@ -44,15 +44,6 @@ AM_INIT_AUTOMAKE([1.15 dist-xz dist-lzip])
AC_CONFIG_MACRO_DIR([m4])
-dnl Additional argument stuff
-AC_ARG_WITH(whiny-user-strftime,
- [AS_HELP_STRING([--with-whiny-user-strftime], [force use of included version of strftime for deficient systems])],
- if test "$withval" = yes
- then
- AC_DEFINE(USE_INCLUDED_STRFTIME, 1,
- [force use of our version of strftime])
- fi
-)
AC_ARG_ENABLE([lint],
[AS_HELP_STRING([--disable-lint],[do not compile in gawk lint checking])],
if test "$enableval" = no
@@ -60,13 +51,6 @@ AC_ARG_ENABLE([lint],
AC_DEFINE(NO_LINT, 1, [disable lint checks])
fi
)
-AC_ARG_ENABLE([severe-portability-problems],
- [AS_HELP_STRING([--enable-severe-portability-problems],[allow really nasty portability problems])],
- if test "$enableval" = yes
- then
- AC_DEFINE(I_DONT_KNOW_WHAT_IM_DOING, 1, [enable severe portability problems])
- fi
-)
AC_ARG_ENABLE([builtin-intdiv0],
[AS_HELP_STRING([--enable-builtin-intdiv0],[enable built-in intdiv0 function])],
if test "$enableval" = yes
@@ -172,8 +156,8 @@ AM_LANGINFO_CODESET
gt_LC_MESSAGES
dnl checks for header files
-AC_CHECK_HEADERS(arpa/inet.h fcntl.h limits.h locale.h libintl.h mcheck.h \
- netdb.h netinet/in.h stdarg.h stddef.h string.h \
+AC_CHECK_HEADERS(arpa/inet.h fcntl.h locale.h libintl.h mcheck.h \
+ netdb.h netinet/in.h stddef.h string.h \
sys/ioctl.h sys/param.h sys/select.h sys/socket.h sys/time.h unistd.h \
termios.h stropts.h wchar.h wctype.h)
AC_HEADER_STDC