aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 01cab0e0..c6c7e501 100644
--- a/configure.ac
+++ b/configure.ac
@@ -133,7 +133,7 @@ then
# enable debugging using macros also
if test "$GCC" = yes
then
- CFLAGS="$CFLAGS -Wall -fno-builtin -g3"
+ CFLAGS="$CFLAGS -Wall -fno-builtin -g3 -ggdb3"
fi
AC_MSG_RESULT([yes])
else
@@ -485,3 +485,11 @@ then
AC_CONFIG_SUBDIRS(extension)
fi
AC_OUTPUT
+if test "$GCC" = yes && test -f $srcdir/.developing
+then
+ for i in . support extension
+ do
+ sed '/-O2/s///' $i/Makefile > foo
+ mv foo $i/Makefile
+ done
+fi