aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5b2507e5..2f42f4e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,6 +287,11 @@ AC_FUNC_MBRTOWC
dnl check for dynamic linking
dnl This is known to be very primitive
+dnl On MirBSD (and probably other systems), don't even try.
+case `uname` in
+MirBSD | MirOS)
+ : ;;
+*)
AC_CHECK_HEADER(dlfcn.h,
[
# Check this separately. Some systems have dlopen
@@ -306,6 +311,8 @@ AC_CHECK_HEADER(dlfcn.h,
fi
fi
])
+ ;;
+esac
dnl check for how to use getpgrp
dnl have to hardwire it for VMS POSIX. Sigh.