aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d865ebe4..510805c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -119,13 +119,6 @@ dnl need -D_SYSV3 for ISC
CFLAGS="$CFLAGS -D_SYSV3"
fi
-dnl check for systems where libc is borked for regex handling
-case $host_os in
-mirbsd*)
- AC_DEFINE([LIBC_IS_BORKED], 1, [libc is broken for regex handling])
- ;;
-esac
-
dnl Set the programming language for checks. Fortunately,
dnl this only needs to be set once, since everything is in C.
AC_LANG([C])
@@ -276,7 +269,7 @@ AC_CHECK_FUNCS(atexit btowc fmod getgrent getgroups grantpt \
memcmp memcpy memcpy_ulong memmove memset \
memset_ulong mkstemp posix_openpt setenv setlocale setsid sigprocmask \
snprintf strchr \
- strerror strftime strncasecmp strcoll strtod strtoul \
+ strerror strftime strcasecmp strncasecmp strcoll strtod strtoul \
system tmpfile towlower towupper tzset usleep waitpid wcrtomb \
wcscoll wctype)
dnl this check is for both mbrtowc and the mbstate_t type, which is good
@@ -314,7 +307,7 @@ EOF
if test "$GCC" = yes; then
case $host_os in
linux*|freebsd*)
- LDFLAGS="$LDFLAGS -export-dynamic"
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
;;
esac
fi