aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b7d59f0e..bccd2351 100644
--- a/configure.ac
+++ b/configure.ac
@@ -295,6 +295,10 @@ AC_CHECK_HEADER(dlfcn.h,
if test "$gawk_have_dlopen" = yes
then
AC_DEFINE([DYNAMIC], 1, [dynamic loading is possible])
+ if uname | $EGREP -i 'linux|freebsd' > /dev/null
+ then
+ LDFLAGS="$LDFLAGS -export-dynamic"
+ fi
fi
])