aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 4 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 8662ca2b..a6972ab2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -88,11 +88,7 @@ if test -f $srcdir/.developing
then
# add other debug flags as appropriate, save GAWKDEBUG for emergencies
CFLAGS="$CFLAGS -DARRAYDEBUG -DYYDEBUG -DLOCALEDEBUG"
- if grep dbug $srcdir/.developing
- then
- CFLAGS="$CFLAGS -DDBUG"
- LIBS="$LIBS dbug/libdbug.a"
- fi
+
# turn on compiler warnings if we're doing development
# enable debugging using macros also
if test "$GCC" = yes
@@ -258,9 +254,9 @@ AC_CHECK_FUNC(getaddrinfo, [AC_DEFINE(HAVE_GETADDRINFO, 1, [have getaddrinfo])],
[AC_DEFINE(HAVE_GETADDRINFO, 1,
[have getaddrinfo])])])
-AC_CHECK_LIB(m, fmod)
-AC_CHECK_LIB(m, isinf)
-AC_CHECK_LIB(m, ismod)
+AC_SEARCH_LIBS(fmod, m)
+AC_SEARCH_LIBS(isinf, m)
+AC_SEARCH_LIBS(ismod, m)
dnl Don't look for libsigsegv on OSF/1, gives us severe headaches
case $host_os in
osf1) : ;;