aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e5715d7..3d1c8837 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -61,10 +61,12 @@ EXTRA_DIST = \
# The order to do things in.
# Build explicitly in "." in order to build gawk first, so
# that `make check' without a prior `make' works.
+# Build in awklib after in doc, since we want to extract
+# sample files if doc/gawk.texi changed.
SUBDIRS = \
. \
- awklib \
doc \
+ awklib \
po \
extension \
test
@@ -144,6 +146,9 @@ CLEANFILES = core core.*
# We want hard links for install-exec-hook, below
LN= ln
+# For some make's, e.g. OpenBSD, that don't define this
+RM = rm -f
+
# First, add a link from gawk to gawk-X.Y.Z.
#
# For GNU systems where gawk is awk, add a link to awk.