aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 0d2efd18..1040a77e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -193,9 +193,9 @@ awkgram.c: awkgram.y
if cmp -s y.tab.h $*.h; then rm -f y.tab.h; else mv y.tab.h $*.h; fi; \
else :; fi
-command.c: command.y
- $(YACC) -p zz $<
- sed 's/parse error/syntax error/g' < y.tab.c | awk -f "$(srcdir)"/bisonfix.awk command > $*.c && rm y.tab.c
+command.c: command.y awkgram.c
+ $(YACC) -o $@ -p zz $<
+ sed 's/parse error/syntax error/g' < $@ > $@.tmp && mv $@.tmp $@
# This is for my development & testing.
efence: gawk