aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 0 insertions, 20 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 01c98ace..80c3d501 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,27 +29,8 @@ project (gawk C)
include(cmake/configure.cmake)
-find_package(BISON REQUIRED)
-if (${BISON_FOUND} STREQUAL "TRUE")
- BISON_TARGET(awkgram awkgram.y ${CMAKE_SOURCE_DIR}/awkgram.c)
-endif()
-#http://www.cmake.org/cmake/help/v2.8.10/cmake.html#module:FindGettext
-find_package(Gettext REQUIRED)
-if (GETTEXT_FOUND STREQUAL "TRUE")
- include_directories(${GETTEXT_INCLUDE_DIR})
-else ()
- message( FATAL_ERROR "Gettext not found" )
-endif()
-find_package(LATEX)
-include(GNUInstallDirs)
-include(GetPrerequisites)
-
set (EXTRA_LIBS "")
-DefineLibraryIfAvailable(m sin "" HAVE_LIBM)
-DefineLibraryIfAvailable(mpfr mpfr_add_si "" HAVE_MPFR)
-DefineLibraryIfAvailable(c socket "" HAVE_SOCKETS)
-
if (${HAVE_MPFR})
set (EXTRA_LIBS ${EXTRA_LIBS} mpfr gmp)
endif ()
@@ -57,7 +38,6 @@ if (${DYNAMIC})
set (EXTRA_LIBS ${EXTRA_LIBS} ${CMAKE_DL_LIBS} )
endif ()
-
include_directories(${CMAKE_SOURCE_DIR})
if("${CMAKE_SYSTEM_NAME}" STREQUAL "Windows")