summaryrefslogtreecommitdiffstats
path: root/newlib/libc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'newlib/libc/configure.in')
-rw-r--r--newlib/libc/configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/newlib/libc/configure.in b/newlib/libc/configure.in
index 1a42c1323..d88c38679 100644
--- a/newlib/libc/configure.in
+++ b/newlib/libc/configure.in
@@ -140,6 +140,16 @@ AC_SUBST(sys_dir)
dnl iconv library will be compiled if --enable-newlib-iconv option is enabled
AM_CONDITIONAL(ENABLE_NEWLIB_ICONV, test x${newlib_iconv} != x)
+dnl Autoconf 2.59 doesn't support the AC_TYPE_LONG_DOUBLE macro. Instead of:
+dnl AC_TYPE_LONG_DOUBLE
+dnl AM_CONDITIONAL(HAVE_LONG_DOUBLE, test x"$ac_cv_type_long_double" = x"yes")
+dnl we specify our own long double test.
+AC_CACHE_CHECK([Checking long double support], [acnewlib_cv_type_long_double],
+ [AC_TRY_COMPILE([], [long double foo = 0.0L;],
+ [acnewlib_cv_type_long_double = yes;],
+ [acnewlib_cv_type_long_double = no;])])
+AM_CONDITIONAL(HAVE_LONG_DOUBLE, test x"$acnewlib_cv_type_long_double" = x"yes")
+
if test -n "${machine_dir}"; then
if test "${use_libtool}" = "yes"; then
LIBC_MACHINE_LIB=machine/${machine_dir}/lib${machine_dir}.${aext}