summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJason Merrill <jason@redhat.com>2000-08-12 00:49:39 +0000
committerJason Merrill <jason@redhat.com>2000-08-12 00:49:39 +0000
commit86bf05d54094008ba6e8a1c692d4a71879ee6590 (patch)
tree69e1b05468b8141a285711510a38fbdd37cf0f86 /configure.in
parent427b6d036e1351981b66950f10c8cfee69112e84 (diff)
downloadcygnal-86bf05d54094008ba6e8a1c692d4a71879ee6590.tar.gz
cygnal-86bf05d54094008ba6e8a1c692d4a71879ee6590.tar.bz2
cygnal-86bf05d54094008ba6e8a1c692d4a71879ee6590.zip
* configure.in (CC_FOR_TARGET, CHILL_FOR_TARGET,
CXX_FOR_TARGET): Add -B$$r/gcc/ here. (FLAGS_FOR_TARGET): Not here. (CHILL_FOR_TARGET, CXX_FOR_TARGET): Don't check the list of languages.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 5 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 49f81741e..88c6b1736 100644
--- a/configure.in
+++ b/configure.in
@@ -1220,15 +1220,6 @@ else
fi
FLAGS_FOR_TARGET=
-if test -d ${topsrcdir}/gcc; then
- # Directories specified with -B are searched for libraries after those
- # specified with -L, but for headers (in sub-directory `include')
- # before those specified with -I and -isystem. Fortunately, we don't
- # expect include directories to exist in build_tooldir/{bin,lib} (see
- # below), and we want gcc/include to be searched first.
- FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -B$$r/gcc/'
-fi
-
case " $skipdirs " in
*" target-newlib "*) ;;
*)
@@ -1270,7 +1261,7 @@ fi
if test "x${CC_FOR_TARGET+set}" = xset; then
:
elif test -d ${topsrcdir}/gcc; then
- CC_FOR_TARGET='$$r/gcc/xgcc'
+ CC_FOR_TARGET='$$r/gcc/xgcc -B$$r/gcc/'
elif test "$host" = "$target"; then
CC_FOR_TARGET='$(CC)'
else
@@ -1285,10 +1276,8 @@ esac
if test "x${CHILL_FOR_TARGET+set}" = xset; then
:
-elif test -d ${topsrcdir}/gcc &&
- echo ",${enable_languages-`echo ${LANGUAGES-CHILL} | tr ' ' ','`}," |
- grep ',CHILL,' > /dev/null ; then
- CHILL_FOR_TARGET='$$r/gcc/xgcc -L$$r/gcc/ch/runtime/'
+elif test -d ${topsrcdir}/gcc; then
+ CHILL_FOR_TARGET='$$r/gcc/xgcc -B$$r/gcc/ -L$$r/gcc/ch/runtime/'
elif test "$host" = "$target"; then
CHILL_FOR_TARGET='$(CC)'
else
@@ -1301,10 +1290,8 @@ esac
if test "x${CXX_FOR_TARGET+set}" = xset; then
:
-elif test -d ${topsrcdir}/gcc &&
- echo ",${enable_languages-`echo ${LANGUAGES-c++} | tr ' ' ','`}," |
- grep ',c[+][+],' > /dev/null ; then
- CXX_FOR_TARGET='$$r/gcc/g++ -nostdinc++ '$libstdcxx_flags
+elif test -d ${topsrcdir}/gcc; then
+ CXX_FOR_TARGET='$$r/gcc/g++ -B$$r/gcc/ -nostdinc++ '$libstdcxx_flags
elif test "$host" = "$target"; then
CXX_FOR_TARGET='$(CXX)'
else