summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2001-04-25 21:41:21 +0000
committerAlexandre Oliva <aoliva@redhat.com>2001-04-25 21:41:21 +0000
commit71bb5ea46b89786179ff890ccfa59c311dc9a0d8 (patch)
tree0d26eb1a1f44a700a75f70dab376005c36431b39 /configure.in
parent968d91b2e6156e84c9fa5a6534364861446549f8 (diff)
downloadcygnal-71bb5ea46b89786179ff890ccfa59c311dc9a0d8.tar.gz
cygnal-71bb5ea46b89786179ff890ccfa59c311dc9a0d8.tar.bz2
cygnal-71bb5ea46b89786179ff890ccfa59c311dc9a0d8.zip
* configure.in (libgcj_saved): Copy from $libgcj.
(libgcj): Zero out if --enable-libgcj; add to noconfigdirs is --disable-libgcj.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cc8f34f87..d5db06585 100644
--- a/configure.in
+++ b/configure.in
@@ -572,6 +572,22 @@ case "${host}" in
esac
+# Save it here so that, even in case of --enable-libgcj, if the Java
+# front-end isn't enabled, we still get libgcj disabled.
+libgcj_saved=$libgcj
+case $enable_libgcj in
+yes)
+ # If we reset it here, it won't get added to noconfigdirs in the
+ # target-specific build rules, so it will be forcibly enabled
+ # (unless the Java language itself isn't enabled).
+ libgcj=
+ ;;
+no)
+ # Make sure we get it printed in the list of not supported target libs.
+ noconfigdirs="$noconfigdirs ${libgcj}"
+ ;;
+esac
+
case "${target}" in
*-*-netware)
noconfigdirs="$noconfigdirs ${libstdcxx_version} target-newlib target-libiberty target-libgloss target-libffi"