summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorDoug Evans <dje@google.com>2000-08-20 22:56:17 +0000
committerDoug Evans <dje@google.com>2000-08-20 22:56:17 +0000
commit43a5b89bdde71257f8b584c94cc04400cabd554a (patch)
tree13b82bd3bd6b76386a6d715615274e2be57acab5 /configure.in
parent542243394334a592acfda2ea707c95fe5cb4a16a (diff)
downloadcygnal-43a5b89bdde71257f8b584c94cc04400cabd554a.tar.gz
cygnal-43a5b89bdde71257f8b584c94cc04400cabd554a.tar.bz2
cygnal-43a5b89bdde71257f8b584c94cc04400cabd554a.zip
* Makefile.in (ALL_MODULES): Add all-cgen.
(CROSS_CHECK_MODULES,INSTALL_MODULES,CLEAN_MODULES): Similarily. (all-cgen): New target. (all-opcodes,all-sim): Depend on all-cgen. * configure.in (host_tools): Add cgen. Only configure cgen if --enable-cgen-maint.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a442d532a..9af1fd16d 100644
--- a/configure.in
+++ b/configure.in
@@ -60,7 +60,7 @@ fi
# these tools are built for the host environment
# Note, the powerpc-eabi build depends on sim occurring before gdb in order to
# know that we are building the simulator.
-host_tools="texinfo byacc flex bison binutils ld gas gcc sim gdb make patch prms send-pr gprof gdbtest tgas etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool ispell grep diff rcs cvssrc fileutils shellutils time textutils wdiff find emacs emacs19 uudecode hello tar gzip indent recode release sed utils guile perl apache inet gawk findutils snavigator libtool gettext zip"
+host_tools="texinfo byacc flex bison binutils ld gas gcc cgen sim gdb make patch prms send-pr gprof gdbtest tgas etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool ispell grep diff rcs cvssrc fileutils shellutils time textutils wdiff find emacs emacs19 uudecode hello tar gzip indent recode release sed utils guile perl apache inet gawk findutils snavigator libtool gettext zip"
# these libraries are built for the target environment, and are built after
# the host libraries and the host tools (which may be a cross compiler)
@@ -916,6 +916,11 @@ case "${noconfigdirs}" in
*target-newlib*) noconfigdirs="$noconfigdirs target-libgloss" ;;
esac
+# Only configure cgen if --enable-cgen-maint.
+if [ "x$enable_cgen_maint" != xyes ] ; then
+ noconfigdirs="$noconfigdirs cgen"
+fi
+
# Make sure we don't let GNU ld be added if we didn't want it.
if [ x$with_gnu_ld = xno ]; then
use_gnu_ld=no