summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2006-01-04 13:11:22 +0000
committerPaolo Bonzini <pbonzini@redhat.com>2006-01-04 13:11:22 +0000
commite3c08f94a01ad50d38cc199d1c00212ae090805d (patch)
tree0750277f4216577976ec5a03aba970a8cda1aca5 /configure.in
parentd58ca0b320690d34ac713809a83296a8e6ba1a3f (diff)
downloadcygnal-e3c08f94a01ad50d38cc199d1c00212ae090805d.tar.gz
cygnal-e3c08f94a01ad50d38cc199d1c00212ae090805d.tar.bz2
cygnal-e3c08f94a01ad50d38cc199d1c00212ae090805d.zip
2006-01-04 Paolo Bonzini <bonzini@gnu.org>
Sync from gcc: 2006-01-04 Paolo Bonzini <bonzini@gnu.org> PR bootstrap/24252 * Makefile.def (flags_to_pass): Add STAGE1_CFLAGS and STAGE1_LANGUAGES. * Makefile.tpl (OBJDUMP): New. (EXTRA_HOST_FLAGS): Add it. (EXTRA_GCC_FLAGS): Remove flags already specified in flags_to_pass. * Makefile.tpl (stage[+id+]-start, stage[+id+]-end): Do not try to use symbolic links between directories. Avoid race conditions or make them harmless. * configure.in: Do not try to use symbolic links between directories. * Makefile.def (LEAN): Pass. * Makefile.tpl (LEAN): Define. (stage[+id+]-start): Accept that the previous directory does not exist, if the bootstrap is lean. (stage[+id+]-bubble): Invoke lean bootstrap commands after stage[+id+]-start. Use a makefile variable and an `if' instead of a configure substitution. ([+compare-target+]): Likewise. ([+bootstrap-target+]-lean): New. * configure.in: Remove lean bootstrap support from here. * Makefile.in: Regenerate. * configure: Regenerate. 2006-01-02 Andreas Schwab <schwab@suse.de> * configure.in: When reconfiguring remove Makefile in all stage directories. * configure: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in62
1 files changed, 15 insertions, 47 deletions
diff --git a/configure.in b/configure.in
index 50ffdd973..ec635d8b3 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
-# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998,
-# 1999, 2000, 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
+# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
+# 2000, 2001, 2002, 2003, 2004, 2005, 2006 Free Software Foundation, Inc.
#
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@@ -657,8 +657,8 @@ case "${target}" in
noconfigdirs="$noconfigdirs gdb target-newlib target-libgloss ${libgcj}"
;;
i[[3456789]]86-*-rdos*)
- noconfigdirs="$noconfigdirs gdb target-newlib target-libgloss"
- ;;
+ noconfigdirs="$noconfigdirs gdb target-newlib target-libgloss"
+ ;;
m32r-*-*)
noconfigdirs="$noconfigdirs ${libgcj}"
;;
@@ -1739,7 +1739,7 @@ INSTALL_GDB_TK=`echo ${GDB_TK} | sed s/-all-/-install-/g`
# not to nest @if/@endif pairs, because configure will not warn you at all.
AC_ARG_ENABLE([bootstrap],
-[ --enable-bootstrap[=lean] Enable bootstrapping [no]],,
+[ --enable-bootstrap Enable bootstrapping [yes if native build]],,
enable_bootstrap=default)
# Issue errors and warnings for invalid/strange bootstrap combinations.
@@ -1760,17 +1760,17 @@ case "$have_compiler:$host:$target:$enable_bootstrap" in
enable_bootstrap=no ;;
# We have a compiler and we are in a native configuration, bootstrap is ok
- yes:$build:$build:yes | yes:$build:$build:lean)
+ yes:$build:$build:yes)
;;
# Other configurations, but we have a compiler. Assume the user knows
# what he's doing.
- yes:*:*:yes | yes:*:*:lean)
+ yes:*:*:yes)
AC_MSG_WARN([trying to bootstrap a cross compiler])
;;
# No compiler: if they passed --enable-bootstrap explicitly, fail
- no:*:*:yes | no:*:*:lean)
+ no:*:*:yes)
AC_MSG_ERROR([cannot bootstrap without a compiler]) ;;
# Fail if wrong command line
@@ -1782,15 +1782,10 @@ esac
# Adjust the toplevel makefile according to whether bootstrap was selected.
case "$enable_bootstrap" in
yes)
- bootstrap_lean='#'
- bootstrap_suffix=bootstrap ;;
- lean)
- bootstrap_lean=''
bootstrap_suffix=bootstrap ;;
no)
bootstrap_suffix=no-bootstrap ;;
esac
-AC_SUBST(bootstrap_lean)
for module in ${build_configdirs} ; do
if test -z "${no_recursion}" \
@@ -1805,10 +1800,13 @@ for module in ${build_configdirs} ; do
/^@endif build-$module-$bootstrap_suffix\$/d"
done
for module in ${configdirs} ; do
- if test -z "${no_recursion}" \
- && test -f ${module}/Makefile; then
- echo 1>&2 "*** removing ${module}/Makefile to force reconfigure"
- rm -f ${module}/Makefile
+ if test -z "${no_recursion}"; then
+ for file in stage*-${module}/Makefile ${module}/Makefile; do
+ if test -f ${file}; then
+ echo 1>&2 "*** removing ${file} to force reconfigure"
+ rm -f ${file}
+ fi
+ done
fi
extrasub="$extrasub
/^@if $module\$/d
@@ -2290,36 +2288,6 @@ case $build in
esac
AC_SUBST(stage1_cflags)
-# It makes debugging easier if we create as symlinks the stage directories
-# gcc for stageN-gcc and stagePREV-gcc for stage(N-1). In case this is not
-# possible, however, we can resort to mv.
-AC_CACHE_CHECK([if symbolic links between directories work],
-[gcc_cv_prog_ln_s_dir],
-[if test "${LN_S}" = "ln -s" \
- && mkdir confdir.s1 \
- && ln -s confdir.s1 confdir.s2 \
- && echo timestamp1 > confdir.s1/conftest.1 \
- && cmp confdir.s1/conftest.1 confdir.s2/conftest.1 \
- && echo timestamp2 > confdir.s2/conftest.2 \
- && cmp confdir.s1/conftest.2 confdir.s1/conftest.2 \
- && rm -f confdir.s2; then
- gcc_cv_prog_ln_s_dir=yes
-else
- gcc_cv_prog_ln_s_dir=no
-fi
-rm -rf confdir.s1 confdir.s2])
-
-case ${gcc_cv_prog_ln_s_dir} in
- yes)
- CREATE_LINK_TO_DIR='ln -s $$1 $$2'
- UNDO_LINK_TO_DIR='rm -f $$1' ;;
- *)
- CREATE_LINK_TO_DIR='mv $$1 $$2'
- UNDO_LINK_TO_DIR='mv $$1 $$2' ;;
-esac
-AC_SUBST(CREATE_LINK_TO_DIR)
-AC_SUBST(UNDO_LINK_TO_DIR)
-
# Enable -Werror in bootstrap stage2 and later.
# Change the default to "no" on release branches.
AC_ARG_ENABLE(werror,