summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMark Mitchell <mark@codesourcery.com>2005-07-27 18:00:57 +0000
committerMark Mitchell <mark@codesourcery.com>2005-07-27 18:00:57 +0000
commit9b992990df3a391dac5d0e2eb843fa1ace07f45f (patch)
tree9b83fc473995f91d8b4908bead7970a1e05e7438 /configure.in
parent09b490911cf904e41bd66f69281c4537632ff468 (diff)
downloadcygnal-9b992990df3a391dac5d0e2eb843fa1ace07f45f.tar.gz
cygnal-9b992990df3a391dac5d0e2eb843fa1ace07f45f.tar.bz2
cygnal-9b992990df3a391dac5d0e2eb843fa1ace07f45f.zip
* config/mt-gnu (CXXFLAGS): Include SYSROOT_CFLAGS_FOR_TARGET.
* Makefile.tpl (SYSROOT_CFLAGS_FOR_TARGET): New variable. (CFLAGS_FOR_TARGET): Use it. (CXXFLAGS_FOR_TARGET): Likewise. * Makefile.in: Regenerated. * configure.in (--with-build-sysroot): New option. * configure: Regenerated.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d7c006c12..f5877a708 100644
--- a/configure.in
+++ b/configure.in
@@ -1405,6 +1405,15 @@ esac
copy_dirs=
+AC_ARG_WITH([build-sysroot],
+ [ --with-build-sysroot=sysroot
+ use sysroot as the system root during the build],
+ [if test x"$withval" != x ; then
+ SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
+ fi],
+ [SYSROOT_CFLAGS_FOR_TARGET=])
+AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
+
# Handle --with-headers=XXX. If the value is not "yes", the contents of
# the named directory are copied to $(tooldir)/sys-include.
if test x"${with_headers}" != x && test x"${with_headers}" != xno ; then