summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2006-02-14 09:29:42 +0000
committerPaolo Bonzini <pbonzini@redhat.com>2006-02-14 09:29:42 +0000
commit00bc9d7ff2e02911cbe77f3867468671c3a5039b (patch)
tree80037e70d085c08e8484ea275a43071c2996221e /configure.in
parent207258c87d0a0fd76b3aaccb3c8915f57e68be20 (diff)
downloadcygnal-00bc9d7ff2e02911cbe77f3867468671c3a5039b.tar.gz
cygnal-00bc9d7ff2e02911cbe77f3867468671c3a5039b.tar.bz2
cygnal-00bc9d7ff2e02911cbe77f3867468671c3a5039b.zip
2006-02-14 Paolo Bonzini <bonzini@gnu.org>
Sync from gcc: 2006-01-31 Richard Guenther <rguenther@suse.de> Paolo Bonzini <bonzini@gnu.org> * Makefile.def (target_modules): Add libgcc-math target module. * configure.in (target_libraries): Add libgcc-math target library. (--enable-libgcc-math): New configure switch. * Makefile.in: Re-generate. * configure: Re-generate. * libgcc-math: New toplevel directory. 2006-01-18 Richard Henderson <rth@redhat.com> Jakub Jelinek <jakub@redhat.com> Diego Novillo <dnovillo@redhat.com> * libgomp: New directory. * Makefile.def: Add target_module libgomp. * Makefile.in: Regenerate. * configure.in (target_libraries): Add target-libgomp. * configure: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 43 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 1acdb3398..785ace829 100644
--- a/configure.in
+++ b/configure.in
@@ -148,10 +148,12 @@ target_libraries="target-libiberty \
target-libstdc++-v3 \
target-libmudflap \
target-libssp \
+ target-libgcc-math \
target-libgfortran \
${libgcj} \
target-libobjc \
- target-libada"
+ target-libada \
+ target-libgomp"
# these tools are built using the target libraries, and are intended to
# run only in the target environment
@@ -315,6 +317,21 @@ if test "${ENABLE_LIBSSP}" != "yes" ; then
noconfigdirs="$noconfigdirs target-libssp"
fi
+# Set the default so we build libgcc-math for ix86 and x86_64
+AC_ARG_ENABLE(libgcc-math,
+[ --enable-libgcc-math Builds libgcc-math directory],,
+[
+case "${target}" in
+ i?86-* | x86_64-* )
+ enable_libgcc_math=yes ;;
+ *)
+ enable_libgcc_math=no ;;
+esac
+])
+if test "${enable_libgcc_math}" != "yes"; then
+ noconfigdirs="$noconfigdirs target-libgcc-math"
+fi
+
# Save it here so that, even in case of --enable-libgcj, if the Java
# front-end isn't enabled, we still get libgcj disabled.
libgcj_saved=$libgcj
@@ -341,7 +358,7 @@ no)
;;
"")
case "${target}" in
- *-*-linux*-gnu | *-*-gnu* | *-*-k*bsd*-gnu)
+ *-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
# Enable libmudflap by default in GNU and friends.
;;
*-*-freebsd*)
@@ -354,6 +371,30 @@ no)
esac
esac
+# Allow --disable-libgomp to exclude target-libgomp
+case $enable_libgomp in
+yes)
+ ;;
+no)
+ noconfigdirs="$noconfigdirs target-libgomp"
+ ;;
+"")
+ # Enable libgomp by default on hosted POSIX systems.
+ case "${target}" in
+ *-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
+ ;;
+ *-*-netbsd* | *-*-freebsd* | *-*-openbsd*)
+ ;;
+ *-*-solaris2* | *-*-sysv4* | *-*-irix* | *-*-osf* | *-*-hpux*)
+ ;;
+ *-*-darwin* | *-*-aix*)
+ ;;
+ *)
+ noconfigdirs="$noconfigdirs target-libgomp"
+ ;;
+ esac
+esac
+
case "${target}" in
*-*-chorusos)