summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2009-09-25 19:25:04 +0000
committerNick Clifton <nickc@redhat.com>2009-09-25 19:25:04 +0000
commit358d4e3cb0a44d725e54494c97b2ddbaa2281b7b (patch)
tree3916dae7a1e337eca6b5952c6878c9506488a6ab /configure.ac
parent0986f933655beff96d02e98e5c30726bb2e65cbe (diff)
downloadcygnal-358d4e3cb0a44d725e54494c97b2ddbaa2281b7b.tar.gz
cygnal-358d4e3cb0a44d725e54494c97b2ddbaa2281b7b.tar.bz2
cygnal-358d4e3cb0a44d725e54494c97b2ddbaa2281b7b.zip
* configure.ac: Pass any --cache-file=/dev/null option on to
subconfigures. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e7d44db83..91b2bca07 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2632,9 +2632,11 @@ AC_SUBST_FILE(serialization_dependencies)
# Base args. Strip norecursion, cache-file, srcdir, host, build,
# target, nonopt, and variable assignments. These are the ones we
-# might not want to pass down to subconfigures. Also strip
-# program-prefix, program-suffix, and program-transform-name, so that
-# we can pass down a consistent program-transform-name.
+# might not want to pass down to subconfigures. The exception being
+# --cache-file=/dev/null, which is used to turn off the use of cache
+# files altogether, and which should be passed on to subconfigures.
+# Also strip program-prefix, program-suffix, and program-transform-name,
+# so that we can pass down a consistent program-transform-name.
baseargs=
keep_next=no
skip_next=no
@@ -2673,6 +2675,13 @@ do
esac
case "$ac_arg" in
+ --cache-file=/dev/null | \
+ -cache-file=/dev/null )
+ # Handled here to avoid the test to skip args below.
+ baseargs="$baseargs '$ac_arg'"
+ # Assert: $separate_arg should always be no.
+ keep_next=$separate_arg
+ ;;
--no*)
continue
;;