summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2007-08-18 15:19:10 +0000
committerJoseph Myers <joseph@codesourcery.com>2007-08-18 15:19:10 +0000
commitfcc5fef0b048ebfa14126a3949190fa174423507 (patch)
tree8f1a2d066447e1ebff158a986cef64b3b1567e13 /configure.ac
parent5b62123cf613f82ce94a9a4f8bfd13997c762be8 (diff)
downloadcygnal-fcc5fef0b048ebfa14126a3949190fa174423507.tar.gz
cygnal-fcc5fef0b048ebfa14126a3949190fa174423507.tar.bz2
cygnal-fcc5fef0b048ebfa14126a3949190fa174423507.zip
2007-08-18 Paul Brook <paul@codesourcery.com>
Joseph Myers <joseph@codesourcery.com> * Makefile.tpl (DEBUG_PREFIX_CFLAGS_FOR_TARGET): New. (CFLAGS_FOR_TARGET, CXXFLAGS_FOR_TARGET): Include it. * Makefile.in: Regenerate. * configure.ac (--with-debug-prefix-map): New. * configure: Regenerate. config: 2007-08-18 Paul Brook <paul@codesourcery.com> Joseph Myers <joseph@codesourcery.com> * mt-gnu (CXXFLAGS_FOR_TARGET): Add $(DEBUG_PREFIX_CFLAGS_FOR_TARGET).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7353fef3a..e111852ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1593,6 +1593,18 @@ AC_ARG_WITH([build-sysroot],
[SYSROOT_CFLAGS_FOR_TARGET=])
AC_SUBST(SYSROOT_CFLAGS_FOR_TARGET)
+AC_ARG_WITH([debug-prefix-map],
+ [ --with-debug-prefix-map='A=B C=D ...'
+ map A to B, C to D ... in debug information],
+ [if test x"$withval" != x; then
+ DEBUG_PREFIX_CFLAGS_FOR_TARGET=
+ for debug_map in $withval; do
+ DEBUG_PREFIX_CFLAGS_FOR_TARGET="$DEBUG_PREFIX_CFLAGS_FOR_TARGET -fdebug-prefix-map=$debug_map"
+ done
+ fi],
+ [DEBUG_PREFIX_CFLAGS_FOR_TARGET=])
+AC_SUBST(DEBUG_PREFIX_CFLAGS_FOR_TARGET)
+
# Handle --with-headers=XXX. If the value is not "yes", the contents of
# the named directory are copied to $(tooldir)/sys-include.
if test x"${with_headers}" != x && test x"${with_headers}" != xno ; then