summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Elliston <bje@gnu.org>2007-08-13 01:32:36 +0000
committerBen Elliston <bje@gnu.org>2007-08-13 01:32:36 +0000
commitfc7c811f0359760ed8ce007ac4c21c17cd9fe485 (patch)
treeadba5a1a8123fd15f5cef5aa25aa2085cb901759 /configure.ac
parent8b6f3d4c8602752d48f70397986c88b6b9ff5619 (diff)
downloadcygnal-fc7c811f0359760ed8ce007ac4c21c17cd9fe485.tar.gz
cygnal-fc7c811f0359760ed8ce007ac4c21c17cd9fe485.tar.bz2
cygnal-fc7c811f0359760ed8ce007ac4c21c17cd9fe485.zip
* configure.ac (TOPLEVEL_CONFIGURE_ARGUMENTS, baseargs): Pass
--silent if $silent. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da88113f0..e9eea64e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,9 @@ do
# Add the quoted argument to the list.
TOPLEVEL_CONFIGURE_ARGUMENTS="$TOPLEVEL_CONFIGURE_ARGUMENTS $ac_arg"
done
+if test "$silent" = yes; then
+ TOPLEVEL_CONFIGURE_ARGUMENTS="$TOPLEVEL_CONFIGURE_ARGUMENTS --silent"
+fi
# Remove the initial space we just introduced and, as these will be
# expanded by make, quote '$'.
TOPLEVEL_CONFIGURE_ARGUMENTS=`echo "x$TOPLEVEL_CONFIGURE_ARGUMENTS" | sed -e 's/^x *//' -e 's,\\$,$$,g'`
@@ -2178,6 +2181,9 @@ EOF_SED
gcc_transform_name=`cat conftestsed.out`
rm -f conftestsed.out
baseargs="$baseargs --program-transform-name='${gcc_transform_name}'"
+if test "$silent" = yes; then
+ baseargs="$baseargs --silent"
+fi
# For the build-side libraries, we just need to pretend we're native,
# and not use the same cache file. Multilibs are neither needed nor