summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDJ Delorie <dj@redhat.com>2007-07-11 19:12:27 +0000
committerDJ Delorie <dj@redhat.com>2007-07-11 19:12:27 +0000
commitb301596e9117e9921f8c119fbae1490c0578a738 (patch)
tree845261624bad9d6e75589291026b649622d525e7 /configure.ac
parent6fc4fe923a8a36df5a1d58f22e69647bdfd83875 (diff)
downloadcygnal-b301596e9117e9921f8c119fbae1490c0578a738.tar.gz
cygnal-b301596e9117e9921f8c119fbae1490c0578a738.tar.bz2
cygnal-b301596e9117e9921f8c119fbae1490c0578a738.zip
Merge from gcc:
2007-07-11 Ralf Wildenhues <Ralf.Wildenhues@gmx.de> * configure.ac: Rewrite 'configure --help' strings to look nicer. * configure: Regenerate. 2007-07-11 Ralf Wildenhues <Ralf.Wildenhues@gmx.de> * configure.ac: Add some missing m4 quotation. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 28 insertions, 28 deletions
diff --git a/configure.ac b/configure.ac
index b46935963..5f67ce462 100644
--- a/configure.ac
+++ b/configure.ac
@@ -332,7 +332,7 @@ esac
AC_ARG_ENABLE(libada,
-[ --enable-libada Builds libada directory],
+[ --enable-libada build libada directory],
ENABLE_LIBADA=$enableval,
ENABLE_LIBADA=yes)
if test "${ENABLE_LIBADA}" != "yes" ; then
@@ -340,7 +340,7 @@ if test "${ENABLE_LIBADA}" != "yes" ; then
fi
AC_ARG_ENABLE(libssp,
-[ --enable-libssp Builds libssp directory],
+[ --enable-libssp build libssp directory],
ENABLE_LIBSSP=$enableval,
ENABLE_LIBSSP=yes)
@@ -1081,16 +1081,16 @@ have_gmp=no
# Specify a location for mpfr
# check for this first so it ends up on the link line before gmp.
-AC_ARG_WITH(mpfr-dir, [ --with-mpfr-dir=PATH This option has been REMOVED],
+AC_ARG_WITH(mpfr-dir, [ --with-mpfr-dir=PATH this option has been REMOVED],
AC_MSG_ERROR([The --with-mpfr-dir=PATH option has been removed.
Use --with-mpfr=PATH or --with-mpfr-include=PATH plus --with-mpfr-lib=PATH]))
-AC_ARG_WITH(mpfr, [ --with-mpfr=PATH Specify prefix directory for installed MPFR package
+AC_ARG_WITH(mpfr, [ --with-mpfr=PATH specify prefix directory for installed MPFR package.
Equivalent to --with-mpfr-include=PATH/include
plus --with-mpfr-lib=PATH/lib])
AC_ARG_WITH(mpfr_include, [ --with-mpfr-include=PATH
- Specify directory for installed MPFR include files])
-AC_ARG_WITH(mpfr_lib, [ --with-mpfr-lib=PATH Specify the directory for the installed MPFR library])
+ specify directory for installed MPFR include files])
+AC_ARG_WITH(mpfr_lib, [ --with-mpfr-lib=PATH specify directory for the installed MPFR library])
if test "x$with_mpfr" != x; then
gmplibs="-L$with_mpfr/lib $gmplibs"
@@ -1113,15 +1113,15 @@ if test "x$with_mpfr$with_mpfr_include$with_mpfr_lib" = x && test -d ${srcdir}/m
fi
# Specify a location for gmp
-AC_ARG_WITH(gmp-dir, [ --with-gmp-dir=PATH This option has been REMOVED],
+AC_ARG_WITH(gmp-dir, [ --with-gmp-dir=PATH this option has been REMOVED],
AC_MSG_ERROR([The --with-gmp-dir=PATH option has been removed.
Use --with-gmp=PATH or --with-gmp-include=PATH plus --with-gmp-lib=PATH]))
-AC_ARG_WITH(gmp, [ --with-gmp=PATH Specify prefix directory for the installed GMP package
+AC_ARG_WITH(gmp, [ --with-gmp=PATH specify prefix directory for the installed GMP package.
Equivalent to --with-gmp-include=PATH/include
plus --with-gmp-lib=PATH/lib])
-AC_ARG_WITH(gmp_include, [ --with-gmp-include=PATH Specify directory for installed GMP include files])
-AC_ARG_WITH(gmp_lib, [ --with-gmp-lib=PATH Specify the directory for the installed GMP library])
+AC_ARG_WITH(gmp_include, [ --with-gmp-include=PATH specify directory for installed GMP include files])
+AC_ARG_WITH(gmp_lib, [ --with-gmp-lib=PATH specify directory for the installed GMP library])
if test "x$with_gmp" != x; then
@@ -1365,7 +1365,7 @@ if test -d ${srcdir}/gcc; then
done
AC_ARG_ENABLE(stage1-languages,
-[ --enable-stage1-languages[=all] choose additional languages to build during
+[ --enable-stage1-languages@<:@=all@:>@ choose additional languages to build during
stage1. Mostly useful for compiler development.],
[case ,${enable_stage1_languages}, in
,no,|,,)
@@ -1426,8 +1426,8 @@ done
# Check for Boehm's garbage collector
AC_ARG_ENABLE(objc-gc,
-[ --enable-objc-gc enable the use of Boehm's garbage collector with
- the GNU Objective-C runtime.],
+[ --enable-objc-gc enable use of Boehm's garbage collector with the
+ GNU Objective-C runtime],
[case ,${enable_languages},:${enable_objc_gc}:${noconfigdirs} in
*,objc,*:*:yes:*target-boehm-gc*)
AC_MSG_ERROR([Boehm's garbage collector was requested yet not supported in this configuration])
@@ -1582,7 +1582,7 @@ ACX_TOOL_DIRS
copy_dirs=
AC_ARG_WITH([build-sysroot],
- [ --with-build-sysroot=sysroot
+ [ --with-build-sysroot=SYSROOT
use sysroot as the system root during the build],
[if test x"$withval" != x ; then
SYSROOT_CFLAGS_FOR_TARGET="--sysroot=$withval"
@@ -1693,10 +1693,10 @@ case "${target}" in
alpha*-*-*vms*)
md_exec_prefix=/gnu/lib/gcc-lib
;;
- i[34567]86-pc-msdosdjgpp*)
+ i[[34567]]86-pc-msdosdjgpp*)
md_exec_prefix=/dev/env/DJDIR/bin
;;
- i[34567]86-*-sco3.2v5*)
+ i[[34567]]86-*-sco3.2v5*)
if test $with_gnu_as = yes; then
md_exec_prefix=/usr/gnu/bin
else
@@ -1727,7 +1727,7 @@ case "${target}" in
*-*-nto-qnx* | \
*-*-rtems* | \
*-*-solaris2* | \
- *-*-sysv[45]* | \
+ *-*-sysv[[45]]* | \
*-*-vxworks* | \
*-wrs-windiss)
md_exec_prefix=/usr/ccs/bin
@@ -1941,7 +1941,7 @@ INSTALL_GDB_TK=`echo ${GDB_TK} | sed s/-all-/-install-/g`
# not to nest @if/@endif pairs, because configure will not warn you at all.
AC_ARG_ENABLE([bootstrap],
-[ --enable-bootstrap Enable bootstrapping [yes if native build]],,
+[ --enable-bootstrap enable bootstrapping @<:@yes if native build@:>@],,
enable_bootstrap=default)
# Issue errors and warnings for invalid/strange bootstrap combinations.
@@ -2035,10 +2035,10 @@ extrasub="$extrasub
# Create the serialization dependencies. This uses a temporary file.
AC_ARG_ENABLE([serial-configure],
-[ --enable-serial-[{host,target,build}-]configure
- Force sequential configuration of
+[ --enable-serial-@<:@{host,target,build}-@:>@configure
+ force sequential configuration of
sub-packages for the host, target or build
- machine, or all sub-packages])
+ machine, or all sub-packages])
case ${enable_serial_configure} in
yes)
@@ -2450,7 +2450,7 @@ AC_SUBST(CXXFLAGS)
# Target tools.
AC_ARG_WITH([build-time-tools],
- [ --with-build-time-tools=path
+ [ --with-build-time-tools=PATH
use given path to find target tools during the build],
[case x"$withval" in
x/*) ;;
@@ -2589,8 +2589,8 @@ AC_SUBST(stage1_cflags)
# Enable --enable-checking in stage1 of the compiler.
AC_ARG_ENABLE(stage1-checking,
-[ --enable-stage1-checking[=all] choose additional checking for stage1
- of the compiler.],
+[ --enable-stage1-checking@<:@=all@:>@ choose additional checking for stage1
+ of the compiler],
[stage1_checking=--enable-checking=${enable_stage1_checking}],
[if test "x$enable_checking" = xno; then
stage1_checking=--enable-checking
@@ -2615,22 +2615,22 @@ AC_SUBST(stage2_werror_flag)
# Flags needed to enable html installing and building
AC_ARG_WITH(datarootdir,
-[ --with-datarootdir Use datarootdir as the data root directory.],
+[ --with-datarootdir use datarootdir as the data root directory.],
[datarootdir="\${prefix}/${withval}"],
[datarootdir="\${prefix}/share"])
AC_ARG_WITH(docdir,
-[ --with-docdir Install documentation in this directory.],
+[ --with-docdir install documentation in this directory.],
[docdir="\${prefix}/${withval}"],
[docdir="\${datarootdir}/doc"])
AC_ARG_WITH(pdfdir,
-[ --with-pdfdir Install pdf in this directory.],
+[ --with-pdfdir install pdf in this directory.],
[pdfdir="\${prefix}/${withval}"],
[pdfdir="\${docdir}"])
AC_ARG_WITH(htmldir,
-[ --with-htmldir Install html in this directory.],
+[ --with-htmldir install html in this directory.],
[htmldir="\${prefix}/${withval}"],
[htmldir="\${docdir}"])