summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2011-05-04 21:45:47 +0000
committerJoseph Myers <joseph@codesourcery.com>2011-05-04 21:45:47 +0000
commitfab6d5dd0387dd959d9c5c8a00970b801d58503e (patch)
treee68d8a74cfb545e708eca9fa78f3c3ca4fd4b206 /configure.ac
parent975757698f521dffeb360ced0a5540a922856500 (diff)
downloadcygnal-fab6d5dd0387dd959d9c5c8a00970b801d58503e.tar.gz
cygnal-fab6d5dd0387dd959d9c5c8a00970b801d58503e.tar.bz2
cygnal-fab6d5dd0387dd959d9c5c8a00970b801d58503e.zip
* configure.ac: Remove code setting special library locations for
hppa*64*-*-hpux11*. Remove code setting compiler for sparc-sun-solaris2*. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 0 insertions, 36 deletions
diff --git a/configure.ac b/configure.ac
index c41abf3df..bfbb80556 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2334,14 +2334,6 @@ if test x${with_stabs} = x ; then
esac
fi
-# hpux11 in 64bit mode has libraries in a weird place. Arrange to find
-# them automatically.
-case "${host}" in
- hppa*64*-*-hpux11*)
- extra_host_args="$extra_host_args -x-libraries=/usr/lib/pa20_64 -x-includes=/usr/X11R6/include"
- ;;
-esac
-
# Some systems (e.g., one of the i386-aix systems the gas testers are
# using) don't handle "\$" correctly, so don't use it here.
tooldir='${exec_prefix}'/${target_noncanonical}
@@ -2385,34 +2377,6 @@ case $we_are_ok in
esac
rm -f conftest*
-# The Solaris /usr/ucb/cc compiler does not appear to work.
-case "${host}" in
- sparc-sun-solaris2*)
- CCBASE="`echo ${CC-cc} | sed 's/ .*$//'`"
- if test "`type $CCBASE | sed 's/^[[^/]]*//'`" = "/usr/ucb/cc" ; then
- could_use=
- test -d /opt/SUNWspro/bin && could_use="/opt/SUNWspro/bin"
- if test -d /opt/cygnus/bin ; then
- if test "$could_use" = "" ; then
- could_use="/opt/cygnus/bin"
- else
- could_use="$could_use or /opt/cygnus/bin"
- fi
- fi
- if test "$could_use" = "" ; then
- echo "Warning: compilation may fail because you're using"
- echo "/usr/ucb/cc. You should change your PATH or CC "
- echo "variable and rerun configure."
- else
- echo "Warning: compilation may fail because you're using"
- echo "/usr/ucb/cc, when you should use the C compiler from"
- echo "$could_use. You should change your"
- echo "PATH or CC variable and rerun configure."
- fi
- fi
- ;;
-esac
-
# Decide which environment variable is used to find dynamic libraries.
case "${host}" in
*-*-hpux*) RPATH_ENVVAR=SHLIB_PATH ;;