summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <iant@google.com>2010-12-07 21:20:22 +0000
committerIan Lance Taylor <iant@google.com>2010-12-07 21:20:22 +0000
commitf2588cb91dc7af00b9b2f8349c2a7dc563168fe1 (patch)
treed00b93a738a16ebdae70fb364e06b08d41713c48 /configure.ac
parent1d1dde068c1187dde485524c5713104c4afadbef (diff)
downloadcygnal-f2588cb91dc7af00b9b2f8349c2a7dc563168fe1.tar.gz
cygnal-f2588cb91dc7af00b9b2f8349c2a7dc563168fe1.tar.bz2
cygnal-f2588cb91dc7af00b9b2f8349c2a7dc563168fe1.zip
* configure.ac: Always set default for poststage1_ldflags to
-static-libstdc++ -static-libgcc.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 440f066ac..fcf5ba2c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1561,10 +1561,10 @@ AC_ARG_WITH(boot-ldflags,
poststage1_ldflags=$withval
fi],
[poststage1_ldflags=
- # With --enable-build-with-cxx, default to linking libstdc++ and
- # libgcc statically. But if the user explicitly specified the
- # libraries to use, trust that they are doing what they want.
- if test "$ENABLE_BUILD_WITH_CXX" = "yes" -a "$poststage1_libs" = ""; then
+ # In stages 2 and 3, default to linking libstdc++ and libgcc
+ # statically. But if the user explicitly specified the libraries to
+ # use, trust that they are doing what they want.
+ if test "$poststage1_libs" = ""; then
poststage1_ldflags="-static-libstdc++ -static-libgcc"
fi])
AC_SUBST(poststage1_ldflags)