summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2009-09-29 21:31:07 +0000
committerPaolo Bonzini <pbonzini@redhat.com>2009-09-29 21:31:07 +0000
commite634d38754276af9b9474e2030d6d4355c570b2a (patch)
treec64399f03d84f20ad72f9603c457cc39a60ae05e /configure.ac
parente97ad66a846702f4fb66a2ea8a5191dc97b3e9dc (diff)
downloadcygnal-e634d38754276af9b9474e2030d6d4355c570b2a.tar.gz
cygnal-e634d38754276af9b9474e2030d6d4355c570b2a.tar.bz2
cygnal-e634d38754276af9b9474e2030d6d4355c570b2a.zip
2009-09-29 Paolo Bonzini <bonzini@gnu.org>
Sync from gcc: 2009-09-26 Kaveh R. Ghazi <ghazi@caip.rutgers.edu> * configure.ac: Update minimum MPC version to 0.7. * configure: Regenerate.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 91b2bca07..0e68f43a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1358,7 +1358,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
CFLAGS="$CFLAGS $mpcinc"
AC_MSG_CHECKING([for the correct version of mpc.h])
AC_TRY_COMPILE([#include <mpc.h>],[
- #if MPC_VERSION < MPC_VERSION_NUM (0,6,0)
+ #if MPC_VERSION < MPC_VERSION_NUM (0,7,0)
choke me
#endif
], [AC_MSG_RESULT([yes]); have_mpc=maybe],
@@ -1404,6 +1404,7 @@ if test -d ${srcdir}/gcc && test "x$have_gmp" = xno; then
mpc_proj (n, n, MPC_RNDNN);
mpc_neg (n, n, MPC_RNDNN);
mpc_sqr (n, n, MPC_RNDNN);
+ mpc_pow (n, n, n, MPC_RNDNN);
mpc_clear (n);
], [AC_MSG_RESULT([yes]); have_mpc=yes],
[AC_MSG_RESULT([no]); have_mpc=no; mpclibs= ; mpcinc= ])