summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorH.J. Lu <hjl.tools@gmail.com>2010-11-23 18:10:14 +0000
committerH.J. Lu <hjl.tools@gmail.com>2010-11-23 18:10:14 +0000
commit6805373e945a2f7b6de68cd333ec214e7de59fca (patch)
tree65ac9c76f343f3c6cfba14e26691f516ac41c9c9 /configure.ac
parent32ab31795a37956f9a024b6f0d142e999c827151 (diff)
downloadcygnal-6805373e945a2f7b6de68cd333ec214e7de59fca.tar.gz
cygnal-6805373e945a2f7b6de68cd333ec214e7de59fca.tar.bz2
cygnal-6805373e945a2f7b6de68cd333ec214e7de59fca.zip
Properly check default linker.
2010-11-23 H.J. Lu <hongjiu.lu@intel.com> PR binutils/12258 * configure.ac: Correct comments for --enable-gold/--enable-ld. Properly check default linker. * configure: Regnerated.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 626bb4e10..294f241bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,13 +327,17 @@ esac
# Handle --enable-gold, --enable-ld.
# --disable-gold [--enable-ld]
# Build only ld. Default option.
-# --enable-gold[=default] [--enable-ld]
+# --enable-gold [--enable-ld]
+# Build both gold and ld. Install gold as "ld.gold", install ld
+# as "ld.bfd" and "ld".
+# --enable-gold=default [--enable-ld]
# Build both gold and ld. Install gold as "ld.gold" and "ld",
# install ld as "ld.bfd".
# --enable-gold[=default] --disable-ld
# Build only gold, which is then installed as both "ld.gold" and "ld".
# --enable-gold --enable-ld=default
-# Build both gold (installed as "gold") and ld (installed as "ld").
+# Build both gold (installed as "ld.gold") and ld (installed as "ld"
+# and ld.bfd).
# In other words, ld is default
# --enable-gold=default --enable-ld=default
# Error.
@@ -387,7 +391,7 @@ ENABLE_LD=yes)
case "${ENABLE_LD}" in
default)
- if test x${default_ld} != xgold; then
+ if test x${default_ld} != x; then
AC_MSG_ERROR([either gold or ld can be the default ld])
fi
;;