summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-10-02 14:42:48 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2010-10-02 14:42:48 +0000
commit65a20d8c1b67c3f0020bed62f472142c50161f1d (patch)
treea76cd3d2a33589ab81b62f8d408e1f7f35813a2e /configure.ac
parentad2b2724a7efba3e39d6c5b6f4f75f6ec1d4e8bb (diff)
downloadcygnal-65a20d8c1b67c3f0020bed62f472142c50161f1d.tar.gz
cygnal-65a20d8c1b67c3f0020bed62f472142c50161f1d.tar.bz2
cygnal-65a20d8c1b67c3f0020bed62f472142c50161f1d.zip
Sync toplevel and config from GCC.
/: Sync from GCC: 2010-09-30 Michael Eager <eager@eagercon.com> * configure.ac (microblaze): Add target-libssp to noconfigdirs. * configure: Regenerate. 2010-09-21 Iain Sandoe <iains@gcc.gnu.org> * configure.ac (enable-lto): Add Darwin to the list of supported lto targets and amend comment. * configure: Regenerate. 2010-09-03 Jack Howarth <howarth@bromo.med.uc.edu> * configure.ac: Enable LTO by default on Darwin. * configure: Regenerate. 2010-07-23 Marc Glisse <marc.glisse@normalesup.org> PR bootstrap/44455 * configure.ac (extra_mpfr_configure_flags): Copy from extra_mpc_gmp_configure_flags. * configure: Re-generated. config/: Sync from GCC: 2010-09-10 Jonathan Yong <jon_y@users.sourceforge.net> * dfp.m4: Enable decimal float for i?86 cygwin and mingw, and for x86_64 mingw.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 10 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index eca08fe3e..be7e992f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -887,7 +887,7 @@ case "${target}" in
noconfigdirs="$noconfigdirs ld binutils gprof target-libgloss ${libgcj}"
;;
microblaze*)
- noconfigdirs="$noconfigdirs gprof ${libgcj}"
+ noconfigdirs="$noconfigdirs gprof target-libssp ${libgcj}"
;;
mips*-sde-elf*)
skipdirs="$skipdirs target-libiberty"
@@ -1348,7 +1348,7 @@ fi
if test "x$with_gmp$with_gmp_include$with_gmp_lib" = x && test -d ${srcdir}/gmp; then
gmplibs='-L$$r/$(HOST_SUBDIR)/gmp/'"$lt_cv_objdir $gmplibs"
gmpinc='-I$$r/$(HOST_SUBDIR)/gmp -I$$s/gmp '"$gmpinc"
- extra_mpfr_configure_flags='--with-gmp-build=$$r/$(HOST_SUBDIR)/gmp'
+ extra_mpfr_configure_flags='--with-gmp-include=$$r/$(HOST_SUBDIR)/gmp --with-gmp-lib=$$r/$(HOST_SUBDIR)/gmp/'"$lt_cv_objdir"
extra_mpc_gmp_configure_flags='--with-gmp-include=$$r/$(HOST_SUBDIR)/gmp --with-gmp-lib=$$r/$(HOST_SUBDIR)/gmp/'"$lt_cv_objdir"
# Do not test the gmp version. Assume that it is sufficient, since
# it is in the source tree, and the library has not been built yet
@@ -1787,17 +1787,19 @@ to specify its location.])
AC_SUBST(libelflibs)
AC_SUBST(libelfinc)
fi],[if test x"$default_enable_lto" = x"yes" ; then
- # On non-ELF platforms, LTO must be explicitly enabled.
- enable_lto=no
+ case $target in
+ *-apple-darwin*) ;;
+ # On other non-ELF platforms, LTO must be explicitly enabled.
+ *) enable_lto=no ;;
+ esac
else
- # Apart from ELF platforms, only Windows supports LTO so far. It
- # would also be nice to check the binutils support, but we don't
+ # Apart from ELF platforms, only Windows and Darwin support LTO so far.
+ # It would also be nice to check the binutils support, but we don't
# have gcc_GAS_CHECK_FEATURE available here. For now, we'll just
# warn during gcc/ subconfigure; unless you're bootstrapping with
# -flto it won't be needed until after installation anyway.
case $target in
- *-cygwin*|*-mingw*) ;;
- *-apple-darwin*) ;;
+ *-cygwin*|*-mingw* | *-apple-darwin*) ;;
*) if test x"$enable_lto" = x"yes"; then
AC_MSG_ERROR([LTO support is not enabled for this target.])
fi