summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandre Oliva <aoliva@redhat.com>2009-09-07 00:44:08 +0000
committerAlexandre Oliva <aoliva@redhat.com>2009-09-07 00:44:08 +0000
commit556620583130230f38875f6bdd269db69e988b4f (patch)
treefac0857190cffa1f673466d04d441b05b69d91a9 /configure.ac
parent99790663b826fa119ce68bfb0891f67eaaefd600 (diff)
downloadcygnal-556620583130230f38875f6bdd269db69e988b4f.tar.gz
cygnal-556620583130230f38875f6bdd269db69e988b4f.tar.bz2
cygnal-556620583130230f38875f6bdd269db69e988b4f.zip
ChangeLog:
* configure.ac (with-build-config): Document. Handle without. Handle missing argument. * configure: Rebuilt. config/ChangeLog: * bootstrap-debug-big.mk (STAGE2_CFLAGS): Drop -gtoggle. * bootstrap-debug-lean.mk: Update comments. (STAGE2_CFLAGS): Likewise. (do-compare): Don't override. ChangeLog: * configure.ac (with-build-config): Document. Handle without. Handle missing argument. * configure: Rebuilt.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 39 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 48fa58019..592a8e3b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2459,13 +2459,49 @@ case "$have_compiler:$host:$target:$enable_bootstrap" in
esac
# Adjust the toplevel makefile according to whether bootstrap was selected.
-case "$enable_bootstrap" in
+case $enable_bootstrap in
yes)
- bootstrap_suffix=bootstrap ;;
+ bootstrap_suffix=bootstrap
+ BUILD_CONFIG=bootstrap-debug
+ ;;
no)
- bootstrap_suffix=no-bootstrap ;;
+ bootstrap_suffix=no-bootstrap
+ BUILD_CONFIG=
+ ;;
esac
+AC_MSG_CHECKING(for default BUILD_CONFIG)
+
+AC_ARG_WITH([build-config],
+ [--with-build-config='NAME NAME2...'
+ Use config/NAME.mk build configuration],
+ [case $with_build_config in
+ yes) with_build_config= ;;
+ no) with_build_config= BUILD_CONFIG= ;;
+ esac])
+
+if test "x${with_build_config}" != x; then
+ BUILD_CONFIG=$with_build_config
+else
+ case $BUILD_CONFIG in
+ bootstrap-debug)
+ if echo "int f (void) { return 0; }" > conftest.c &&
+ ${CC} -c conftest.c &&
+ mv conftest.o conftest.o.g0 &&
+ ${CC} -c -g conftest.c &&
+ mv conftest.o conftest.o.g &&
+ ${srcdir}/contrib/compare-debug conftest.o.g0 conftest.o.g; then
+ :
+ else
+ BUILD_CONFIG=
+ fi
+ rm -f conftest.c conftest.o conftest.o.g0 conftest.o.g
+ ;;
+ esac
+fi
+AC_MSG_RESULT($BUILD_CONFIG)
+AC_SUBST(BUILD_CONFIG)
+
for module in ${build_configdirs} ; do
if test -z "${no_recursion}" \
&& test -f ${build_subdir}/${module}/Makefile; then